28

I recently installed Oracle Virtualbox from their website on Xubuntu 15.04 64-bit. Specifically, Virtualbox 5.0.4. However, when I try to install a virtual machine, it only gives me the option to install a 32-bit OS (as seen below). Is there a way to allow 64-bit OSes?

enter image description here

  • Are you running 32 bit Ubuntu? – Daniel Sep 17 '15 at 15:14
  • Just added an edit clarifying. – eLyUKayEe Sep 17 '15 at 15:31
  • 2
    refer here – Ravan Sep 17 '15 at 15:45
  • 2
    Is VT-x/AMD-V enabled in BIOS? askubuntu.com/questions/256792/… – Takkat Sep 17 '15 at 19:28
  • Basically, this problem occurred due to the installation of docker. docker disable the 64-bit option. you can solve this issue in the following way please refer to the following video: You need to disable the hyper-v option to solve this problem in 30 secs. The practical video is available here. – user880527 Oct 10 '18 at 12:53
22

This is normal if your CPU does not have hardware support for virtualization (Intel VT-x or AMD-v). Older 64-bit CPUs may not support this.

I'm quoting the below one from the Virtualbox forum moderator

You can install 64bit guests on 32bit hosts, so the "bittedness" of the host is not the issue. The issue is that in VirtualBox, hardware support for virtualization (Intel VT-x or AMD-v) is required for certain VMs, which includes all 64bit VMs - regardless of the host.

To enable 64bit guests, run through the following checklist :-

  • Note your exact CPU model or part number, then go online and check its capabilities. The CPU must have 64bit capability and support either Intel or AMD virtualization technologies: VT-x or AMD-v.

  • You usually need to enable VT-x/AMD-v in the host PC BIOS. You need to check with your PC manual or support forum to find out how to boot into the BIOS screen. This is probably not something we here at the VirtualBox forums can help you with. Once you get there you need to look for something buried in a menu, perhaps in the security category. The option may be called something like "Enable Virtualization Technology". If you see "Virtual Directed I/O" then that is a different thing. Remember to reboot your host PC after making BIOS changes - in this case a full restart from power off is required, just resuming from a hibernated state may not do the job.

  • If (1) and (2) are already taken care of, then make sure that no other host apps are already using VT-x/AMD-v. The usual culprits are system level debuggers, other VM platforms, and some resident anti-virus applications. This has become a particular issue with 64bit Windows desktop and server hosts - especially Win8/Win2k12/Win10, since these may enable Microsoft's Hyper-v VM platform by default: this grabs ownership of VT-x and won't play nice with VirtualBox.

  • When creating a VM, make sure you choose the 64-bit version of the guest OS template in | General | Basic | Version, e.g. choose "Ubuntu (64 bit)" and not "Ubuntu" or "Ubuntu (32bit)". This has become more important since VirtualBox 4.3.x, because choosing the correct template also allows other modern processor features to be visible to the guest - it's not just about 64bit capability any more.

3

May be your system is 32 bit, if not i.e if it is 64 bit machine then may be the virtualization technology is not enabled in BIOS. you have to enable virtualization technology in BIOS..you can find relevant videos on how to enable virtualization through BIOS.

  • With virtualization off in BIOS, we have 32 bit only options, with it on, we get 64 bit as well. – rtaft Oct 10 '18 at 12:56

protected by Community Oct 10 '18 at 13:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.