41

This question already has an answer here:

I have problem with this function because i work in Maya and other 3D applications that use this key combination... This option on Ubuntu 11.04 was in "window" section so i could change it to something else to avoid conflicts... where is this located in Ubuntu 11.10?

marked as duplicate by terdon Dec 10 '16 at 11:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • did any answer help you solve the maya issue? as Autodesk doesn't officially support Maya for Ubuntu, it'd be interesting to know, and if so, maybe mark which answer was helpful? cheers – JorgeArtware Jun 3 '14 at 11:16
38

It’s a Compiz plugin.

Install Compiz Config Settings Manager (sudo apt-get install compizconfig-settings-manager in a terminal) and open it.

Once opened, search for a “Move Window” plugin. Select it, and disable or change the first option, “Initiate Window Move”.

CCSM window

For Unity 2d:

  • 1
    The original poster didn't specify what version of Unity he was using. Ubuntu users with computers that can't handle Compiz are running Unity-2D with Metacity. The solution you posted doesn't work for them. If possible, you should provide both solutions. – user27451 Nov 10 '11 at 11:13
  • 1
    Thank you, I was having trouble with Sublime Text 3 and this helped :) – Aditya M P Aug 6 '13 at 8:19
  • 4
    Disabling "Initiate window movement" option somehow doesn't work for me. Any ideas how I can force compiz to disable it? – disfated Apr 16 '14 at 7:52
  • not sure if it worked for the maya issue (i'm guessing it did) but it did solve it for me (regarding sublime and atom editors) much appreciated, Fitoschido. Also, I recommend Samuel's method even better. – JorgeArtware Jun 3 '14 at 11:10
  • 3
    @disfated disabling also didn't work for me. I had to disable the plugin completely OR set it to something else. I selected all modifier keys + button 20. Hopefully it will never get in the way again! – Brad Goss Mar 29 '16 at 19:04
24

With regard to Fitoschido's answer:

Clicking on the <Alt>Button1 and just disabling it didn't work for me - it had no effect (and when restarting the computer, is was enabled again!). (I'm on Ubuntu 13.10)

What worked was clicking on the <Alt>Button1 and setting it to a different combination, for example ALT-SUPER button1.

  • 1
    That's did the trick for me. Thanks – Alexander Kim Sep 18 '14 at 13:21
  • Also note that setting it to Alt+<Some other key> doesn't seem to work. You must add another option button like super – OneHoopyFrood Aug 28 '15 at 3:27
4

This worked fine for me on Ubuntu 15.10 (command in terminal):

dconf write /org/gnome/desktop/wm/preferences/mouse-button-modifier '"<SUPER>"'

This changes Mouse+Tab combination to Mouse+Super.

  • Thank you very much! This command works like a charm on Ubuntu 16.04. – Pavel Aug 10 '16 at 4:25
1

In conf-editor (you can open it from terminal) go to:
/apps/metacity/general
In the "mouse_button_modifier" option change <Alt> to <Super> or something else.

  • 2
    This does not work for Ubuntu 12.10 – Crimbo Mar 17 '13 at 16:55
  • @Crimbo the conf-editor route is for older versions, the Compiz route is for newer versions like yours. – Novine Oct 30 '13 at 20:31
0

I had this issue with Eagle CAD, and I learned from another forum that you can hold the Super key (windows key for me) before pressing Alt.

Not the answer you're looking for? Browse other questions tagged or ask your own question.