1

How to install older skype version? Group chats not working in ubuntu,but working in live, and windows current version.

  • group chats are 'glitchy' on Linux, especially video calling and such, and they know about the issue. Are you talking about group voice calls or group video calls? – Thomas Ward Sep 16 '15 at 16:53
  • 1
    Older Skype versions won't work anyway, so it's not a solution to the problem. – Gunnar Hjalmarsson Sep 16 '15 at 17:12
  • I`m about text group chat. Funny is I have one chat open in older version and it still working. But new chats not appear. – LeonidMew Sep 16 '15 at 17:26
2

Skype snap package

You don't need to install older versions of Skype anymore. Skype has finally made it into the Ubuntu Software app. Skype has been released as a snap package.

snap find skype
Name      Version      Developer  Notes    Summary
skype     8.14.0.10    skype      classic  One Skype for all your devices. New features. New look. All Skype.

To install Skype in all currently supported versions of Ubuntu open the terminal and type:

sudo snap install skype --classic 
| improve this answer | |
  • You right, Skype in Software are fine. That was old question, when there was problems with skype. – LeonidMew Feb 3 '18 at 14:14
  • and what if you cannot run snap ? – user309383 Feb 8 '18 at 21:11
  • 1
    I found these new questions that may be relevant to your comment: Start Skype (snap installation) and Video and Audio calls are not working in skype (the same version as the Skype snap). If this doesn't help please post your own separate question, so we can get this problem sorted out. – karel Feb 9 '18 at 0:07
3

You can get older versions of Skype in the form of .deb files from: here or here

| improve this answer | |
2

I too recently (early Oct 2018) updated my Skype in Linux Mint (17.3). After that, Skype would open showing list of contacts and chat, then a few seconds later, it would go back to the full-blue start screen, then 'reopen' showing contacts and chats, then repeat once more then simply close. No errors, just closes after a couple of tries.

I reopened Skype, quickly went to Help in the Skype menu, found the version and made a note.

I then used the second link above posted by Tshilidzi Mudau to get the PRIOR version to what I have ( http://skype.en.uptodown.com/ubuntu/old ).

I uninstalled the new 'updated' version, installed the older version from above link and Skype now works. I naturally have a 'notice' in my Skype that there is an 'update' available. I will be ignoring it.

I am yet again reminded why I do not use Microstuffed software.

Thanks for the link.

Hope this helps.

| improve this answer | |
2

Web archive? Just select proper date here:

https://web.archive.org/web/20181117110504/https://repo.skype.com/deb/pool/main/s/skypeforlinux/

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.