1

I did some searches and can't figure out if I have Intel Graphic Cards driver working to be sure it's being used instead of Nvidia drivers. We all know how bad Nvidia blob really is on Ubuntu machines.

Ubuntu 14.04.3 64 bit with

Intel® Core™ i3-2330M processor

I checked synaptic I have have this installed xserver-xorg-video-intelThe output of lspci | grep VGA is

~$ lspci | grep VGA 01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 525M] (rev a1)

The second command I ran lshw -c video

~$ lshw -c video
WARNING: you should run this program as super-user.
 *-display 
 description: VGA compatible controller
 product: GF108M [GeForce GT 525M]
 vendor: NVIDIA Corporation
 physical id: 0
 bus info: pci@0000:01:00.0
 version: a1
 width: 64 bits
 clock: 33MHz
 capabilities: vga_controller bus_master cap_list rom
 configuration: driver=nouveau latency=0
 resources: irq:32 memory:c2000000-c2ffffff memory:b0000000-bfffffff memory:c0000000-c1ffffff ioport:3000(size=128) memory:c3080000-c30fffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

Really want to have Intel Graphic Driver fully installed to take advantage of its native performance.

  • What's so bad with NVIDIA ? - Most problems occur when someone does not install the suitable driver properly ! - I can give you the instruction how to install this "blob" if you want - afterwards you can switch between intel and NVIDIA - please reply ! – cl-netbox Sep 16 '15 at 15:23
  • @cl-netbox the last thing I want to install official Nvidia drivers. Want to use Intel graphic only. I have two machine both without Intel integrated driver but with Nvidia drivers there is absolute no hardware acceleration. I think I have Intel graphic drivers running on concerned notebook mentioned on this question do you know how to verify if it's working? – user280930 Sep 16 '15 at 15:32
  • To check which graphics chip is in use, open System Settings -> Details - post back please. – cl-netbox Sep 16 '15 at 15:40
  • Sorry for the late reply. It says this: 'Gallium 0.4 on NVC1' After reading that, I'm right now installing Nvidia blob via Additional Driver. Chrome://gpu didn't have any hardware acceleration nor any on about:suport on firefox. Really want intel HD graphic doing the hard work instead of the CPU itself. – user280930 Sep 18 '15 at 14:55
0

This is what I meant with my comment in our discussion :

To achieve want you want - switching to intel graphics -
you have to install NVIDIA drivers and Optimus support.

Install the latest current stable NVIDIA driver
from the NVIDIA short-lived branch (355.11) :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-355 nvidia-prime
sudo reboot  

After rebooting open NVIDIA Xserver Settings -> PRIME Profiles and select Intel.
Logout and back in - check PRIME Profiles - now you are using the intel graphics !

  • Thanks. Will try out. Going to remove the Nvidia driver comes in by default in Addtional driver and will get the 'bleeding edge' from the PPA you mentioned. Can you kindly tell me do I need to install drivers from 01.org for the intel HD graphic driver my system has? – user280930 Sep 19 '15 at 18:54
  • Nvida-prime didn't show up. I even did purge nvidia* and reinstalled after booting. Prime won't show up on Nvidia-setting. The screenshot is here s16.postimg.org/wagro7mgl/photo_2015_09_20_10_52_36.jpg – user280930 Sep 20 '15 at 5:53
  • Wanted to add. Tried the manual way: sudo prime-switch nvidia [sudo] password for sarah: /etc/modprobe.d is not a file /etc/modprobe.d is not a file /etc/modprobe.d is not a file /etc/modprobe.d is not a file update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf Didn't work – user280930 Sep 20 '15 at 6:05
  • Your graphics chip seems to not support Optimus technology. Try to force ubuntu to not use the NVIDIA chip. Open etc/default/grub as root and edit the line : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash". Add -> nouveau.modeset=0. Reboot and uninstall 'nvidia' -> sudo apt-get purge nvidia*. Reboot again ... – cl-netbox Sep 20 '15 at 10:41
  • what to do I do if it fails to start as it's unable to use Intel HD graphic like I get a blank screen – user280930 Sep 20 '15 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.