3

I had to reinstall my Java compiler a while back, so I know I broke something. Now when I execute a program in Geany (pressing F5) it produces a geany_run_script.sh script in my working directory. The contents of the script:

#!/bin/sh

rm $0

java "boltzmann"

echo "

------------------
(program exited with code: $?)"         


echo "Press return to continue"
#to be more compatible with shells like dash
dummy_var=""
read dummy_var

...this should be run a terminal automatically, but isn't. I poked around in the Preferences, but couldn't determine where to fix this. Suggestions would be appreciated.

3

Creating run_script is default behaviour. This is due some issue running inside internal vte might cause. However, you can configure it: Edit->Preferences->Terminal->"Don't use run script" (Execute programs in vte has to be enabled for it. Therefor you will need have libvte installed)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.