I am running a VM with Ubuntu 14.04 LTS and tried this command: It's from the yocto documentation and so I guess it isn't wrong.

git clone git://git.yoctoproject.org/poky

And get following error:

Cloning into 'poky'...
fatal: unable to connect to git.yoctoproject.org:
git.yoctoproject.org: Name or service not known

The git server seems to be online when I access the site via browser. However, I found two topics on the site with a similar problem:

No solution, because I have Internet connection inside the VM

Tried both http:// and https://, but it didn't work.

What I assume is, that the problem is associated with the usage of a proxy, but I don't know what to enter:

All Settings >> Network >> Network proxy:

Method: Manual

HTTP Proxy: ;Port: 3128

HTTPS Proxy: ;Port: 3128

FTP Proxy: ;Port: 3128

Socks Host: empty ;Port: empty

(Can't post screenshot!)


user:~$     git --version
             git version 1.9.1

Also tried multiple version with sudo , sudo -s etc...

The firewall seemed to be guilty, although 'the IT guys' assured GIT would work.

What helped, was to install 'socat' and to create a script 'gitproxy'


exec socat STDIO PROXY:$_proxy:$1:$2,proxyport=$_proxyport

And configure git with it:

$  git config --global core.gitProxy <path_to_script>

Solution found here.

  • just tried to do it on my machine, and it worked ... - if it's for example your work network, ask IT guys :) – Marek Bettman Sep 16 '15 at 9:45
  • ping git.yoctoproject.org? – AlexGreg Sep 16 '15 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.