6

I want to install XAMPP on my machine. I downloaded the install file from this website and stored it in my default Downloads directory. The site gives instructions on how to install it, then.

I followed these instructions as below:

chmod 755 xampp-linux-x64-5.6.12-0-installer.run

Then:

sudo ./xampp-linux-x64-5.6.12-0-installer.run

I get the following message:

./xampp-linux-x64-5.6.12-0-installer.run: 
1: ./xampp-linux-x64-5.6.12-0-installer.run: 
Syntax error: Unterminated quoted string

The file command returns:

xampp-linux-x64-5.6.12-0-installer.run: ELF 64-bit LSB executable, x86-64, version 1 (GNU/Linux), statically linked, stripped

I can't find what the problem is... This is quite a basic command, isn't it?

Thanks for help!

9
  • That makes no sense. What you describe should have worked. What's the output of file xampp-linux-x64-5.6.12-0-installer.run? Are you sure you are running the right file? – terdon Sep 15 '15 at 17:13
  • Were you copy-pasting those commands somewhere from a tutorial ? – Sergiy Kolodyazhnyy Sep 15 '15 at 17:16
  • What do you call 'the output of the file'? I did not copy-paste commands. – wiltomap Sep 15 '15 at 17:17
  • @wiltomap file is a command that gives information on the file you run it on. So, file xampp-linux-x64-5.6.12-0-installer.run will tell us what you downloaded. Just open a terminal and run it. Also, we're discussing this question in the chat room, you might want to drop by. – terdon Sep 15 '15 at 17:18
  • @wiltomap there is a terminal command called file. Just type in terminal file xampp-linux-x64-5.6.12-0-installer.run Make sure you're in the same directory as the file – Sergiy Kolodyazhnyy Sep 15 '15 at 17:18
14

Judging by the error you are getting, and found on this site here, the error can occur when you are installing a 64bit version of the program on a 32bit system.

What does the command uname -a return on your system? If you see anything other than x86_64 in that line, then download the 32bit version of the application.

Hope this helps!

2
  • Bingo, OP's system says i686 – Sergiy Kolodyazhnyy Sep 15 '15 at 17:26
  • OK thanks a lot! I'll try the 32-bit version. – wiltomap Sep 15 '15 at 17:26
0

You should use the following steps because your system is configured with 32 bit:-

sudo chmod 755 xampp-linux-x64-5.6.12-0-installer.run
sudo ./xampp-linux-5.6.12-0-installer.run

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.