I am running ubuntu 11.04 on my desktop with wired Internet connection and I am experiencing slow internet connection while the same connection works good for windows machine so it is fix that there is not h/w issue googling this turned into there are some driver issue with ubuntu 11.04

I found this but doesn't work for me.

jigar@jigar-desktop:~$ sudo lshw -class network
[sudo] password for jigar: 
       description: Ethernet interface
       product: 82579V Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eth8
       version: 04
       serial: e0:69:95:a3:ea:1e
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=1.3.10-k2 duplex=full firmware=0.13-4 ip= latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:42 memory:fe500000-fe51ffff memory:fe528000-fe528fff ioport:f080(size=32)
| improve this question | | | | |
  • We need more hardware information to help you, can you look at this question and then edit your question adding the information. – Jorge Castro Oct 16 '11 at 14:51
  • @Jorge which information you need specifically ? it is going very bad experience with ubuntu and internet – Jigar Joshi Oct 20 '11 at 18:50
  • The network card information is probably useful in this case. – Jorge Castro Oct 20 '11 at 18:53
  • @Jorge can you tell me command a quick to get the required information. I upgraded it to 11.10 but the same issue – Jigar Joshi Oct 20 '11 at 18:56
  • It's in the link I posted in my first comment. – Jorge Castro Oct 20 '11 at 19:05

I've had that problem in the past, and in my case found it was because I had IPv6 turned on and my service provider doesnt support it yet. Turning off IPv6 and relying solely on IPv4 fixed the issue for me.

Alternatively I've begun using openDNS For resolutions instead of using the servers from my provider.

| improve this answer | | | | |

I went through a whole host of "solutions" (disabled ipv6, disabled power management, etc etc). I don't know if all of them put together worked plus this one I'm going to write in here, or if it's just this one. But basically, this is the one that did it. The interesting thing is, the whole time I've had this Ubuntu 11.04 thing going, everything except my browsers were fast on the internet. Games worked fine, virtual box pcs running windows 7 were lightening quick on the internet (bridged wireless adapter).

I went into edit connections (drop down from your wifi symbol): selected the wifi connection I'm currently using: click the IPv4 settings tab: method select automatic (dhcp) address only: then in the field that says dns servers: enter the fastest dns server.

How do you know the fastest? I used http://www.grc.com/dns/benchmark.htm with a windows machine. Their software benchmarks the fastest dns servers -just sort the results. I have a hunch that yours will be your router or modem on your internal LAN.

My two fastest dns servers were my wireless router's ip address & my modem's ip address. So you could start by plugging one in then try the other, then try the browser.

So far, the internet has been lightening quick. Hopefully this will last.

| improve this answer | | | | |

I found the problem with my slow internet connection thanks to Jorge Castro I change my wireless connection to Wired connection and it started working. I am using IBM thinkpad x60 Lenovo. And the card seems to have this known problem only with Linux drivers.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.