2

I am running Ubuntu Server 14.04.3 LTS on Hyper-V Server 2012 R2 with installed necessary packages

apt-get install hv-kvp-daemon-init linux-tools-`uname -r` linux-cloud-tools-`uname -r`

After that, when I access any of websites running on the system, network connection of the server is completely down. No inboud traffic, no outbound traffic. IP configuration is still ok, but connection does not work and I have to reboot the server. Then is connection back, I can check for updates, ping other servers, this server responds to ping, I can connect to SSH, everything is ok until I access webpage running on the server, then is connection again completely down.

I tried to remove network adapter and than add it back with a new MAC address (and new IP configuration) but nothing has changed.

The server has both IPv4 and IPv6 native connectivity (dual stack). When I tried to use static IP configuration instead of DHCP for both IPv4+6, nothing has changed. But when I tried to completely disable IPv6 on the server, now I can access websites (using IPv4) and connection works.

So the problem seems to be with IPv6. Does not matter if I have static IPv6 config or use dhcp, when I use IPv6, after accessing website on the server, connection of the server is completely down. When I use only IPv4, averything is OK.

And when I reboot the server, there is one FAIL and hv_netvsc timeout as you can see above. This fail and timeout is present ONLY when I have IPv6 enabled. When is IPv6 disabled, fail and hv_netvsc timeout is gone.

* Killing all remaining processes...                                [fail]
[163.656192] hv_netvsc vmbus_0_14 eth0: timeout before we got a set response...
[168.656061] hv_netvsc vmbus_0_14 eth0: timeout before we got a set response...
[168.656241] hv_netvsc vmbus_0_14 eth0: unable to close device (ret -110).

Linux lws 3.19.0-28-generic #30~14.04.1-Ubuntu SMP Tue Sep 1 09:32:55 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux Apache 2.4.16 PHP 5.6.13 MariaDB 10.0.0.21

I am guessing that the installed packages contain a bug, because on this hypervisor I am running 7 other systems (Windows + 1 Gentoo linux) with IPv6 enabled and everything works fine. And also before I installed the packages, everything was OK.

How to solve it? Thank you

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.