1

I performed a clean install of Ubuntu 15.04 on a Dell XPS 13, but Unity fails to load. After login I see only the desktop background and the mouse pointer but nothing else. Also, right and left clicking does not work and I cannot load a terminal.

I can start Unity by hitting Ctrl+Alt+F1, logging in and running startx, then right click and Open Terminal and then Unity, but that's not a solution. Also even if I do that I don't get the Menu Bar.

I tried pretty much everything I could find on Google to solve this, incl. making sure Unity plugin is enabled on CompizConfig, reinstalling Ubuntu desktop and Unity or running dconf reset -f /org/compiz/ and then setsid unity, but nothing helped.

On Ubuntu 14.04 everything worked fine. Any other ideas?

  • Please edit your question and add output of lspci -k | grep -EA2 'VGA|3D' terminal command. – Pilot6 Sep 15 '15 at 9:03
  • 2
    possible duplicate of Unity doesn't load, no Launcher, no Dash appears – David Foerster Sep 15 '15 at 9:46
  • @Pilot6 running lspci -k | grep -EA2 'VGA|3D' gives 00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09) Subsystem: Dell Device 0665 Kernel driver in use: i915 – Roey Angel Sep 15 '15 at 13:53
0

Problem solved after downgrading to Ubuntu 14.10 and upgrading to Ubuntu 15.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.