I'm trying to run webgl apps in my web browser but whenever I try to, nothing happens. I found that ubuntu-restricted-extras can be installed to enable webgl. One of my friends installed the package on their system and was able to run the webgl app that I was trying to run. When I tried to install the package using the Ubuntu software center, the download stalled so I had to kill the process.

Output of sudo apt-get install ubuntu-restricted-extras

Reading package lists... Done
Building dependency tree       
Reading state information... Done
ubuntu-restricted-extras is already the newest version.
The following packages were automatically installed and are no longer required:
  python-cssselect python-queuelib python-w3lib
Use 'apt-get autoremove' to remove them.
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 145 not upgraded.
1 not fully installed or removed.
Need to get 0 B/27.8 kB of archives.
After this operation, 134 kB of additional disk space will be used.
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
(Reading database ... 286934 files and directories currently installed.)
Preparing to unpack .../ttf-mscorefonts-installer_3.4+nmu1ubuntu1_all.deb ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing archive /var/cache/apt/archives/ttf-mscorefonts-installer_3.4+nmu1ubuntu1_all.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Output of apt-cache policy ubuntu-restricted-extras

$ apt-cache policy ubuntu-restricted-extras
  Installed: 60.1
  Candidate: 60.1
  Version table:
 *** 60.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/multiverse amd64 Packages
        100 /var/lib/dpkg/status
     60 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/multiverse amd64 Packages

What is causing the problem with the installation?


The package ubuntu-restricted-extras is installed as you can see in the output of the command apt-cache policy ubuntu-restricted-extras

Now there are three commands to repair your system.

sudo rm /var/cache/debconf/*.dat 
sudo apt-get update
sudo apt-get install -f

If you have problems to install ttf-mscorefonts-installer, read this.

| improve this answer | |
  • I used all of the commands but the webgl still isn't running. What is ttf-mscorefonts-installer ? Also, for the other post that you provided the link for, should I use your answer that you posted? – loremIpsum1771 Sep 15 '15 at 18:31
  • You have asked three questions at once: 1) webgl 2) ubuntu-restricted-extras 3) DbDriver "config" – A.B. Sep 15 '15 at 18:33
  • Your question was "Error when trying to install ubuntu-restricted-extras". The problem is solved. Webgl is answered here askubuntu.com/questions/299345/… – A.B. Sep 15 '15 at 18:38
  • I tried that answer already, it was only addressing enabling webgl on chrome. It didn't seem to work before. – loremIpsum1771 Sep 15 '15 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.