I recently got a wireless adapter (TP-Link Archer T2UH V1). After plugging it in, I found out that the drivers for Linux are not native on Ubuntu. They do, however, have the drivers available for download (in the form of compilable/ makefile). What I am not sure of is how to install these drivers. I know that I need to build the drivers, place things where they need to be, and tie things together with the kernel. I am not sure how to do this, however, and need some help.

TL;DR: I need to know the terminal commands to install these drivers.

Driver/Device info: http://www.tp-link.com/en/download/Archer-T2UH.html#Driver

Output of lsusb:

Bus 003 Device 004: ID 148f:761a Ralink Technology, Corp.

2 Answers 2


Connect to internet by wire, then run in terminal

sudo apt-get install git build-essential
git clone https://github.com/Myria-de/mt7610u_wifi_sta_v3002_dpo_20130916.git
cd mt7610u_wifi_sta_v3002_dpo_20130916
sudo make install
sudo mkdir -p /etc/Wireless/RT2870STA
sudo cp RT2870STA.dat  /etc/Wireless/RT2870STA/RT2870STA.dat


The dongle should work. The only problem is that you will have to re-install it after each kernel upgrade.

But if you keep the driver folder mt7610u_wifi_sta_v3002_dpo_20130916, then it will be quite easy.

You will need to run only

cd mt7610u_wifi_sta_v3002_dpo_20130916
sudo make install

after a kernel upgrade.

It is also possible to install it using DKMS. In this case it will rebuild automatically on kernel upgrades.


I have a TP-Link T2U Wi-Fi adapter and I was in struggle to find a working driver for Ubuntu 18.10. All the drivers, original and modified, was for previous version of the kernel but nothing useful for the 4.15 kernel. After a painful morning I found a working link to run the TP-Link T2U on the latest kernel.

Here is the link: Trying to fix the MT7610U chipset driver - GitHub

After following the instructions everything worked! I found the link on TP-LINK Archer T2U v2 - WikiDevi.

If you would install the driver you will need to compile the source. To do this you will need install git and clone the repository in your home directory.

sudo apt install git
cd ~
git clone https://github.com/xtknight/mt7610u-linksys-ae6000-wifi-fixes.git
cd mt7610u-linksys-ae6000-wifi-fixes

You can avoid to write the whole directory just type the first letters, for example, mt7610, and press the Tab key.

sudo apt-get install build-essential linux-headers-$(uname -r)
make clean
sudo make install

After these steps the device should work. If you want the driver to work after the updating the kernel I advise to follow the next steps that includes the dkms utility. You will need to work in the directory "mt7610u-linksys-ae6000-wifi-fixes" otherwise the process will not work.

sudo apt-get install dkms  
sudo cp -R . /usr/src/mt7610u_sta-1.0
sudo dkms add mt7610u_sta/1.0
sudo dkms build mt7610u_sta/1.0
sudo dkms install mt7610u_sta/1.0

I hope to be useful for the further development of this OS.

  • This worked for me on Ubuntu 18.04 kernel 4.18.0-24-generic. Thank you @NwalmeThule
    – sevce
    Jun 27, 2019 at 19:41
  • Worked on Ubuntu 18.04 Thanks a lot. Jul 9, 2019 at 7:34
  • This worked for me on Mint 19.1 kernel Thanks
    – Iago Leão
    Aug 18, 2019 at 14:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .