0

I have been using Ubuntu and Linux in general since 2001 and this is the first time that I have not been able to install my printer.

Approx a month ago I upgraded the system from 14.10 to 15.04 doing clean install of / partition, but not touching /home partition. After booting into the system, the printer did not work. So I tried to install it by plugging it like dozens of times before, but it could not be recognized.

I tried HPLIP installation by downloading HPLIP for 64bit Ubuntu and when it came to hp-setup part, I picked to install the USB printer, but HPLIP could not find it.

I switched multiple USB ports without success.

I even tried foo2zjs, but its local settings web page told me that I need proprietary driver to use this printer.

I am clueless as I have not idea how to install this printer which is 110% supported.

lsusb sees the printer and outputs

Bus 001 Device 004: ID 03f0:2b17 Hewlett-Packard LaserJet 1020

  • Yes, work well on Windows laptop. – ubuntico Sep 14 '15 at 15:49
  • Have you tried the install cd it came with? – Daniel Sep 14 '15 at 15:49
  • or equivalent software from online? – Daniel Sep 14 '15 at 15:50
0

It seems that this URL (https://mark911.wordpress.com/2014/10/31/how-to-install-printer-drivers-for-hp-laserjet-1020-in-ubuntu-14-04-lts-without-needing-access-to-openprinting-org-website/) solves the issue. The printer return to life and I was able to print test page.

Namely, HPLIP is buggy and we should not use it. Instead we should use CUPS via foo2zjs.

I will give this a good test over the next few days and weeks and will update the answer if this solution is not long term.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.