2

I installed Ubuntu 15.04 on the VM and I have downloaded Eclipse Luna.
When I try to install it, this error occurs:

An error has occurred.
See the log file /home/master/.eclipse/1473617060_linux_gtk_x86_64/configuration/1442224462970.log

Can you help me to fix it? Thanks

  • 1
    Welcome to AskUbuntu.com! As it stands your question is completely unclear. Please edit the text. Also, if the error you get is described in a log file, please include the contents of that log file. – Jos Sep 14 '15 at 10:42
  • 1
    Please edit your question and include not only how you tried to install Eclipse (downloaded from where, which commands did you run, ...), but also the content of the mentioned error log file. Thank you. – Byte Commander Sep 14 '15 at 10:43
3

You can also use ubuntu-make to easily install Eclipse on Ubuntu.

Ubuntu Make is a command line tool which allows you to download the latest version of popular developer tools on your installation, installing it longside all the required dependencies (which will only ask for root access if you don't have all the required dependencies installed already), enable multi-arch on your system if you are on a 64 bit machine, integrate it with the Unity launcher… Basically, one command to get your system ready to develop with! - Ubuntu Wiki


Installing Ubuntu Make :

Ubuntu make is already in official Ubuntu 15.04 repositories, run :

sudo apt-get install ubuntu-make

Installing Eclipse :

umake ide eclipse
  • Tried your option but eclipse does not appear to be an option using umake, only 'lighttable' and 'visual-studio-code' seem to be options. – George Murtha Sep 30 '16 at 16:19
  • Worked just fine for me. – vmalep Jul 22 '17 at 20:46
3

Update

Instead using the next steps, you could also use the new Eclipse Installer, and have a look at this answer.


  1. Check your Java installation with

    java -version
    

    you should see something like this

    java version "1.8.0_60"
    Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
    Java HotSpot(TM) Server VM (build 25.60-b23, mixed mode)
    

    If necessary install Java

    sudo apt-get install openjdk-8-jdk
    
  2. Remove your Eclipse installation

  3. Download a newer version of eclipse here, eg. Eclipse IDE for Java EE Developers 64-bit.

  4. Extract the archive

    Replace the filename id necessary

    sudo tar xf eclipse-jee-mars-R-linux-gtk-x86_64.tar.gz -C /opt
    
  5. Create a desktop file

    nano ~/.local/share/applications/eclipse.desktop
    

    and add the configuration below

    [Desktop Entry]
    Encoding=UTF-8
    Version=1.0
    Type=Application
    Name=Eclipse JEE
    Comment=Eclipse Integrated Development Environment
    Icon=eclipse
    Exec=/opt/eclipse/eclipse
    StartupNotify=true
    StartupWMClass=Eclipse-JEE
    

    12 Oct 2015 - Update with regards to eclipse.desktop: The value for icon in eclipse.desktop should be path to icon.xpm instead of just eclipse. In my case, the absolute path was /opt/eclipse/icon.xpm.

  6. Start eclipse via your launcher

Tested in 15.04 as VM and in a native 15.04 installation.

  • As you're a reputation 1 user: If this answer helped you, don't forget to click the grey at the left of the answer, which means "yes, this answer is valid"! ;-) – A.B. Sep 15 '15 at 12:27

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.