0

Sometimes, when I reboot the dirty way, I get a menu (black screen, grey letters) .

This is asking to choose what/how I want to launch Ubuntu (very sorry I dont remind which modes).

How is it possible to disable it ? cause the computer has no screen and I dont want boot to be stopped by this screen.

  • 2
  • 1
    Simple solution: Do not hard reboot. Advanced solution: see linked question above. – Byte Commander Sep 14 '15 at 9:59
  • @ByteCommander : thank you but... without screen, users do hard reboot to shut down. Unless a better way is possible (w/o screen) ? – 3pic Sep 14 '15 at 10:02
  • 1
    You have a keyboard? I guess without monitor it's a server release without GUI. Can't you configure it to shutdown if you only touch the power button (ACPI settings or something like that) instead of hard-shutdown? Or you could at least use the magic kernel commands (ALT+SYSRQ+R, then +E, +I, +S, +U and +B, waiting a short time for each command to complete.) – Byte Commander Sep 14 '15 at 10:09
  • Another possibility is to remote login (I use PuTTY for that) and to start the command reboot – Marc Vanhoomissen Sep 14 '15 at 10:37
3

You need to change the grub boot settings..

sudo -H gedit /etc/default/grub

you need to change this line:

GRUB_HIDDEN_TIMEOUT_QUIET=false

to

GRUB_HIDDEN_TIMEOUT_QUIET=true

save configuration file and update grub:

sudo update-grub

There are also some grub setting applications that can help you with this using a gui.

  • @Mackel, thank you. Im about to test it... one stupid question though ? what is the best way to reproduce Grub menu display ? – 3pic Sep 14 '15 at 12:01
  • may be changing that back to true ? – erluxman May 31 '17 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.