I'm trying to backup my home directory (excluding a few folders). The backup is saved on a ~300 GB partition (called backups) of an internal drive, but not the same drive as the home directory. When I try to backup, everything goes OK until at some point Déjà Dup says there is no space left on "backups". The problem is that Déjà Dup only used ~20 GB at this point, so there is a ton of space left. I tried several times without luck.

Why is Déjà Dup saying this?

The size of my home directory, without the excluded folders, is 136 GB.

5 Answers 5


So there are three possible places where Deja Dup might be out of space, and I don't think its error message tells you which. There is a bug filed about that.

  • You may have run out of space on the target partition (which it sounds like you didn't)
  • You may have run out of space in your home directory (~/.cache/deja-dup can get large)
  • You may have run out of space in /tmp
  • 1
    Strange that it explicitly says that "backups" is out of space although the problem it's in another partition. I'll try to free some space in my home directory and in /tmp. Thanks Oct 16, 2011 at 17:02
  • In my case the message is No space left in '/.' (one partition, which is 14% used) while the problem arguably comes from ~/cache/deja-dup (another partition, almost 100% used). This is my own evidence that the error message is misleading as to where the problem actually resides Dec 21, 2017 at 20:23

You can move the location of the cache-directory as follows (create a symlink to a new cache location)

mkdir /othervolume/.deja-dup-cache
mv ~/.cache/deja-dup/* /othervolume/.deja-dup-cache/
rmdir ~/.cache/deja-dup
ln -sf /othervolume/.deja-dup-cache ~/.cache/deja-dup

to change the location of the tmp-directory have a look at the following post: Deja Dup backup, change use of /tmp to another folder/location

  • 1
    Hi, this is something I'd like to do as my .cache directory keeps filling up. Will moving my deja-dup-cache to the same volume I'm backing up pose a security risk to an encrypted backup. My Home is encrypted but my backup volume is not.
    – nhorning
    Nov 17, 2014 at 6:11

I had the same problem

I had >900Gb left on the partition, 13Gb left on the cache folder in ~ and /tmp contained only 13 Kb

I solved the problem just by rebooting


I am operating my root system on an SSD drive, and once read an article about swapping certain folders like /tmp, /var/log, and so on to RAM, which lowers your potential RAM space and the size of the /tmp folder. Exactly this swapping of my /tmp folder caused the no space left error in Deja Dup.

Here is what I did to my fstab back then (sorry, it's in German).

...and parts of the code to put in fstab:

tmpfs   /tmp    tmpfs   nosuid  0   0

So if you made the same changes to your fstab in order to improve performance, simply undo it like this:

# tmpfs /tmp    tmpfs   nosuid  0   0

You might try formatting your backup partition as NTFS.

I had exactly the same error when these two conditions came together:

  • the backup partition is formatted as FAT.
  • the backup included huge files such as virtual hard disc images for VirtualBox.

Formatting the backup partition as NTFS resolved the problem in my case.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .