0

When I mount my "VM" drive to my home folder it shows in the folder tree and an eject button appears next to it.

enter image description here

When I mount my "VM" drive to my root folder it doesn't show in the folder tree and there is no ejection button.

enter image description here

Why does Ubuntu have this behavior? It only makes sense for removable media and other drives that mount to the media folder to behave like this. It doesn't make sense for drives mounted to the home folder.

I'd prefer to mount the drive to my home folder for ease of accessibility and I don't want to be able to accidentally eject it. Is there any way to do this?

1

I submitted a bug report: https://bugs.launchpad.net/ubuntu-gnome/+bug/1501547

The best work around was to create a simlink from the folder in your root directory to your home folder. The following instructions are helpful for making simlinks: https://unix.stackexchange.com/questions/84175/create-a-symbolic-link-relative-to-the-current-directory

0

How do you mount? There are different ways to do that.

One way it should stop it to show up is to use the /etc/fstab file to specify mountpoints.

Why this behavior? It can usually be assumed that if you mount run-time via mount or an auto-mount that this device is ejectable. That's why the eject-button shows up. If you mount into non-home though, you need root permissions, the same applies to ejecting it. As you do not run the filemanager as root, the button won't show up.

  • I used fstab in the examples above. Like it shows, it still shows in the navigation tree when mounting to the home folder. – guttermonk Sep 14 '15 at 22:31
  • @guttermonk Hm, that is unexpected. What's the specific fstab line? In the options (fourth) field try rw,defaults – larkey Sep 15 '15 at 8:56
  • Here's what I used in my fstab: /dev/sdb1 /VM ext4 auto,defaults,user 0 0 – guttermonk Sep 17 '15 at 0:15
  • Using rw,defaults is redundant. defaults = rw, suid, dev, exec, auto, nouser, and async according to https://help.ubuntu.com/community/Fstab – guttermonk Sep 17 '15 at 0:19
  • @guttermonk Yep, didnt read carefully. auto is in defaults though too. I'd remove user as it says: "Allows a user to mount" but when it's mounted on bootup, it may not be necessary. And maybe because it then gets mounted by user it shows up. -- And ofc. I forgot to mention the easy way out: Just mount it somewhere under / but then just symlink from your home to the directory. – larkey Sep 17 '15 at 8:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.