I am using Ubuntu 11.10 in Sony VAIO.

The workspace manager worked in the beginning. But now, when clicking on the workspace button, the 2x2 grid is displayed. Only the upper left workspace is highlighted and the other workspaces are black and faded.

Only the upper left is selectable, which means I effectively have only one usable workspace. I tried CCSM but changing the grid size there had no effect at all.


The way I understand the workspace spread, if you have an active window in a particular workspace, it is coloured in the workspace spread. Or, in case there are no active window, as you seem to have noted, they are dark and faded.

If you select a workspace, the workspace will have an orange outline to indicate that you have selected the workspace. You can refer to the image for clarification. You can select the unused workspace in the workspace spread without any problem.

If this answer is unsatisfactory, you can try resetting Unity to its defaults and see if that helps your problem.


Same problem here. It used to work for a few days, but now I'm stuck with just one workspace. The others are black (even the background isn't shown) and they are unselectable. It might have something to do with the installation of Gnome Shell? I installed that because I wasn't very happy with the new Unity, but eventually I turned back to Unity, finding out three of my workspaces were gone.

A solution is given here: Workspaces don't work on my system but unfortunately it doesn't work for me. It might help you though.

Edit: I see you already tried CCSM, sorry for re-suggesting it.


This is my first fix but I had the same problem as you and just got it to work. Log out of unity and click the sprocket where you sign in to log back in under gnome classic. Right click the lower panel to add workspaces if not already there. Right click the single workspace icon and click on preferences. The rest is pretty simple. Now log back into unity and you will have your workspaces back.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.