0

I have a dual boot system with 3 hard drives: - drive 1 (hitachi 500Gb SATA) has two size-equal partitions NTFS (Windows 7) and Ext4 (Ubuntu 14.04 without swap); - drive 2 (hitachi 500Gb SATA) has one partition NTFS; - drive 3 (Seagate 320Gb IDE) has one partition NTFS.

So the problem is I don`t see my NTFS partition on drive 2 at all in Ubuntu. Windows have an access to all these partitions (except Ext4 of course).

This is my screenshot of blkid command: ims

Maybe the problem is that I have 2 same hitachi hard drives?

5
  • I always turn Windows off completely. – Pavel Sukhorukov Sep 12 '15 at 21:48
  • well then, what does gparted say about the drive – mchid Sep 12 '15 at 21:55
  • i.imgur.com/l5nZfzp.png – Pavel Sukhorukov Sep 12 '15 at 22:09
  • okay, i see. so ubuntu does see the drive when you run blkid. what's the problem? is it that you can't mount the drive or something? – mchid Sep 13 '15 at 0:21
  • What's the output of sudo lsblk -f? – David Foerster Sep 13 '15 at 12:07
1

Looks like blkid gets confused what is actually on the drive. If it truly is just a filesystem without partition table (what seems to be what gparted is thinking), then you still might be able to mount it directly. You can check for it yourself with hex dump:

dd if=/dev/sdc bs=16 count=1 | hexdump -C

If the the line contains NTFS like this:

00000000  eb 52 90 4e 54 46 53 20  20 20 20 00 02 08 00 00  |.R.NTFS    .....|

Then you should have no problems mounting it with: mount -t ntfs /dev/sdc /mnt

If you want to access files as normal desktop user, you probably need to specify -o uid=1000 etc. options as well (refer to man mount.ntfs).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.