37

I have an Nvidia card and two monitors.

Every time I log in to Unity on Ubuntu 11.10, I get this error:

x monitor error

"Could not apply the stored configuration for monitors"

I have tried opening nvidia-settings, but none of my experimental alterations to any of the settings has made a difference.

I can still use my computer, but it seems to break the themes, icons, and styles so my computer looks like Unix circa 1992, which is a pretty annoying.

How do I kill this error?

68

This should fix it:

rm $HOME/.config/monitors.xml
  • For some reason, I don't even have the .config direcotory/and monitors.xml file. I still have this problem still. If I click OK, everything goes and works exactly as planned and all the normal visuals are back. i still want to get rid of that annoying popup though – user37327 Dec 9 '11 at 23:46
  • you will need a directory .config regardless – user53803 Apr 6 '12 at 23:25
  • Had this problem in Linux Mint and Ubuntu using a VM, now working after deleting this conf file :) – jiminikiz Jan 28 '16 at 18:29
  • @user37327: Folders and Files that start with a dot (".") are considered hidden and you have to set some option in your file browser to see them. – Matthias Weiler Mar 21 '16 at 8:06
  • Can I prevent this file from being created automatically? It's rather annoying to have to delete it every time. – Ivan Nov 3 '16 at 10:45

protected by Community Apr 6 '12 at 23:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.