5

Since 11.10 nautilus shows my Desktop in Unity. As I remember correctly, tthis wasn't in 11.04. How can I disable that?

2
7

Having nautilus managing the desktop is default in Ubuntu 11.10. But if you want to disable this feature, you can install gnome-tweak-toolthrough Ubuntu Software Center or just paste in a terminal:

sudo apt-get install gnome-tweak-tool

After it installs find it in your dash. The option is in Desktop and then turn Have file manager handle desktop off.

1
  • In 2017 this does not work the same way. – Pointy Sep 21 '17 at 21:58
11

To configure this, you'll first need to head over to Software Centre and install Gnome Tweak Tool. After you have installed it, you can find the app as Advanced Settings in the dash.

Gnome Tweak Tool lets you change various settings that affect look and feel. The one you want is “Have file manager handle the desktop” in the Desktop section. See the screenshot below.

Note that this setting is stored with gsettings, so you can also access it using a tool called dconf-editor or with this command:

gsettings set org.gnome.desktop.background show-desktop-icons false

The Desktop section of Gnome Tweak Tool


In later versions of Ubuntu (15.04 and possibly earlier?) this setting is renamed to 'Icons on Desktop':

Icons on Desktop screenshot

2
  • I found your answer after a search. I have a similar problem, only I dumped Unity and went for Xubuntu/xfce. Your answer works, but it feels wrong installing a 65meg gnome package to fix a problem in Nautlus in XFCE! Is there a file I need to change, for which this tool is the front end, and if so, where is it/how would I find it myself? Thanks in advance. – user12753 Oct 19 '11 at 20:07
  • 1
    Yes, this setting is stored with gsettings, so you can access it using a tool called dconf-editor or with this command: gsettings set org.gnome.desktop.background show-desktop-icons false – Dylan McCall Jun 23 '12 at 5:34
2

In a terminal window launch Nautilus with the --no-desktop option, (possible, you need to stop Nautilus first with nautilus --quit, see nautilus --help, generally):

 $ nautilus --no-desktop  

(that is, nautilus followed by space, followed by two 'dash' characters and the option name no-desktop. The -- characters when shown in this window display as a continuum.)
Nautilus will launch in a desktop window, and will not take over your desktop.

Any subsequent call to launch Nautilus will also not take over your desktop, provided you leave the first call to Nautilus running.

2
  • If Nautilus does take over, you can kill it in a terminal window. Using Nautilus, browse to /usr/bin and double-click on the /usr/bin/xfce4-terminal binary, (or any other graphical terminal you have installed, e.g. xterm) which will launch a terminal. In the terminal, enter: kill -s 15 $(pidof nautilus) and you will get your desktop back. – user607992 Apr 29 '15 at 11:07
  • Please edit your answer (or question), if you want to add information. Especially file or program output listings (with the help of the {} button in the editor toolbar) are much more readable there and overall it's best to have everything relevant in one place. Also, comments may be deleted for various reasons. – David Foerster Apr 29 '15 at 11:15
1
gsettings set org.gnome.desktop.background show-desktop-icons false

In dconf-manager:

dconf setting to disable desktop icons in nautilus

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.