9

I recently bought a new computer that has an Atheros AR9485 wireless NIC. So far it has been working ok except this one issue: Randomly (as far as I can tell) it will completely lose the internet connection. The indicator in the top panel will still say we are connected but the machine has no internet connectivity whatsoever.

I've been able to get it working again by simply disconnecting from my wireless AP and then reconnecting, but this is annoying. Is there anything I can do to make the connection more stable?

I have tried passing the nohwcrypt=1 to the driver, but that made it impossible to connect to any AP, it just infinity attempted to connect.

sudo modprobe -rfv ath9k
sudo modprobe -v ath9k nohwcrypt=1

I've also tried upgrading my kernel to Linux 4.0 but the problem persists.


Exact chip:

02:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)  

Driver:

$ ls /sys/class/net/wlan0/device/driver/module/drivers
pci:ath9k  platform:ath9k  

and lsmod:

user@host:~$ lsmod | grep -e ath -e ndis
ath3k                  20480  0 
bluetooth             491520  9 bnep,ath3k,btusb
ath9k                 147456  0 
ath9k_common           32768  1 ath9k
ath9k_hw              458752  2 ath9k_common,ath9k
ath                    32768  3 ath9k_common,ath9k,ath9k_hw
mac80211              724992  1 ath9k
cfg80211              540672  4 ath,ath9k_common,ath9k,mac80211 

output from wireless script: http://paste.ubuntu.com/12625978/

I'm running Ubuntu 15.04 on Linux 4.0.0-040000-generic on a Lenovo G510.

I'm wondering now if I could possibly have anything to do with my wireless mouse, which also operates on 2.4GHz..

  • @Seth quick google suggests forcing a bitrate on the wireless network - sudo iwconfig wlan0 rate 54M ... does this help? – fossfreedom Sep 30 '15 at 21:31
  • @fossfreedom No luck. I went a few days without a disconnect (which happens, like I said, it seems random), but today I had another disconnect. – Seth Oct 6 '15 at 20:56
5
+200

I have a Lenovo with a AR9485 but I don't have any close neighbors with wifi and your channel and regulatory settings are the only issues I saw. I know chili555 would suggest using 20Mhz instead of 40 if you have that option on the wireless router

Here is one of his posts copied:

First, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, I have better luck with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get 

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here Then set it temporarily:

sudo iw reg set IS  

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or vim if you don't have the text editor gedit.

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager

1

I've a Realtek based receiver that has the same problem. Disconnecting and reconnecting makes it working again. It is difficult to troubleshoot and it goes in the direction of 'opinion based' but as far as I can tell it is a matter of interference. Many devices like microwave ovens, doorbells, remotes and of course other AP's use the same frequency band which obfuscates or weakens the signal of your AP. Your output file shows lots of other AP's and a relatively weak signal of yours.

The indicator you mention only shows there's a connection with an AP, it basically shows there's a carrier signal. The carrier signal is why you can scan for wireless networks. It does not tell you that anything useful is send or received. If your connection is secured it regularly changes the encryption key and depending on your settings it can even change channel. If the encryption key changes during a period of weak signal the receiver can loose track of it. However it does see the carrier and thinks it is still connected.

There are a few things you can try to improve the situation:

  • Move closer to your AP, but that's not really a solution. Nevertheless this really works.
  • Change the channel of your AP to one that's less crowded. You can try all the channels you can set.
  • If your devices support it try to change to the 5 GHz band which has more channels and is less crowded than the 2.4 GHz band.
  • If the problem persists buy a range extender although this actually worsens the situation in the long term because everyone buys range extenders so more or less there's a wireless war going on these days.
  • I think it is highly probable that what you are describing in paragraph two is what is happening. Unfortunately I am already within 30 feet of the router so getting closer isn't likely to help all that much. This Atheros card doesn't support 5GHz or I would try that. AFAICT I'm on the best channel for my neighbourhood already so that's unlikely to help as well :/ I do have another router but a friend is borrowing it. I don't think he is using it so maybe I can get it back tomorrow and see if that improves anything. – Seth Sep 30 '15 at 21:27
  • Well, upon looking at the whole channel business again it seems I hadn't picked the best channel. Changed it to 7, we'll see if anything gets better. – Seth Sep 30 '15 at 21:51
  • Well, there's no such thing as the 'best' channel. When your neighbors decide to change channels too then this channel can become crowded too. From a theoretically point of view channels 1, 6 or 11 are the best choices because those are the least affected by adjacent channels. However about everyone knows this so those are usually the most crowded channels too. Your choice might be indeed the best choice for a period of time. If it is allowed in your country and your devices support it you might want to try channels 13 or 14. Most people don't use those. – wie5Ooma Sep 30 '15 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.