1

Sometimes, the Software Updater asks for a password (normally when you try to install kernel updates).

Every time that I connect to the Internet, the first thing I do is check for updates. And I got 2 updates today.

When I tried to install them, I was asked for the password to install, but I thought it was strange, since it wasn't a kernel update, so I clicked in the cancel button and the update was canceled.

So, I ran again the Software Updater and I got the same programs update, but after pressing to install, it didn't asked for a password and it installed the updates.

So, the question is: Why it only asked in the first time? Is this a bug or anything? Should I be worried about that?

Thank you guys for helping me.

EDIT: I haven't noticed anything strange on syslog and auth.log.

0
1

When an update is only updating existing packages, you won't be prompted for your password.

However, when new packages are required, such as when there is a change in dependencies for an installed package or a new kernel version, then you are asked to provide a password.

3
  • Thank you for the answer. But still, It asked for the password only in the first time (I canceled the update because it asked for the password, but I tried to update it again, and in the second time it didn't asked for it and installed the updates). Do you know if this is normal? – Nori-chan Sep 12 '15 at 3:07
  • Yes, password is asked once per 15 minutes if entered succesfully. – Rinzwind Sep 12 '15 at 21:32
  • @Rinzwind Sorry, but i think you didn't understand my question. What happenned is that I didn't put my password in the first attempt of update, and it didn't even asked for it in the second attempt. Then, is this a bug? Should I be worried about that? – Nori-chan Sep 13 '15 at 1:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.