4

A whole pile of my applications are no longer launching (xchat, vmware, etc) with this error.

xchat: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

I did some searching and tried a few of the posts found (on this site and others) but I can't seem to get past this. I checked in /usr/lib/x86_64-linux_gnu -- assuming that is where it wants to find the file -- and sure enough there is no entry. I'm just not sure how to put it there.

Can someone help?

2
  • Is this a 64 bit system? Are the programs having problems 64 bit?
    – ubfan1
    Sep 11 '15 at 22:10
  • Yes on both fronts. All these programs were working -- clearly I did something I wasn't supposed to. I was trying to get netExtender for a WebVPN working a few days back. Something I did then must have caused this. Sep 12 '15 at 12:05
4

Reinstall the package libssl1.0.0

sudo apt-get install libssl1.0.0:amd64  

The 64 bit shared library should be at

/lib/x86_64-linux-gnu/libssl.so.1.0.0

with a link to it at

/usr/lib/x86_64-linux-gnu/libssl.so  

The static library is at

/usr/lib/x86_64-linux-gnu/libssl.a

If it's just the links missing, you can replace them yourself without doing a package reinstall.


Looks like the file was deleted (or moved --see if locate libssl.so.1 finds it). Of course, the package manager would know nothing about that, so try the -f force on the install, and if that fails, try the apt-get --reinstall switch.

2
  • Hi ubfan, ... I ran the package installer command and the feedback I got was that libssl1.0.0 was already at the newest version. I checked /lib/x86_64-linux-gnu/libssl.so.1.0.0 and the file was not there, however the other two you referenced we're there. In fact the second one showed up as lrwxrwxrwx 1 root root 37 Jun 11 11:32 libssl.so -> /lib/x86_64-linux-gnu/libssl.so.1.0.0 .. but the fact that the file it is linking to is not there I suppose is the issue. Can I force it to install even it "it is already there"? (OS seems to be confused) Sep 14 '15 at 11:44
  • The --reinstall flag did the trick. I didn't even know that was an option. Thanks so much ubfan1 Sep 14 '15 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.