0

I've had problems with multiple ruby versions installed, couldn't install animation gem properly. The latest Compass has it included so it might solve it for me. I don't need ruby for anything else so ruby version isn't important for me.

$ gem list

*** LOCAL GEMS ***

animation (0.1.alpha.3)
chunky_png (1.2.8)
compass (0.12.2)
compass-core (1.0.3)
compass-import-once (1.0.5)
ffi (1.9.3)
fssm (0.2.10)
i18n (0.7.0)
multi_json (1.11.2)
oily_png (1.1.0)
rb-fsevent (0.9.5)
rb-inotify (0.9.2)
rdoc (3.9.4)
sass (3.4.18, 3.2.12)


$ sass -v 
Sass 3.4.18 (Selective Steve)


$ compass -v 
Errno::ENOENT on line ["25"] of /usr/lib/ruby/vendor_ruby/compass/version.rb: No such file or directory - /usr/lib/ruby/vendor_ruby/compass/../../VERSION.yml
Run with --trace to see the full backtrace
0

Got the same error as @prkos, this is a know bug: https://bugs.launchpad.net/ubuntu/+source/ruby-compass/+bug/1100018

Please try: sudo gem install compass.

| improve this answer | |
  • Thank you, it worked, not sure why now. $ gem list *** LOCAL GEMS *** animation (0.1.alpha.3) chunky_png (1.2.8) compass (1.0.3, 0.12.2) compass-core (1.0.3) compass-import-once (1.0.5) ffi (1.9.3) fssm (0.2.10) i18n (0.7.0) multi_json (1.11.2) oily_png (1.1.0) rb-fsevent (0.9.5) rb-inotify (0.9.2) rdoc (3.9.4) sass (3.4.18, 3.2.12) $ sass -v Sass 3.4.18 (Selective Steve) $ compass -v Compass 1.0.3 (Polaris) Copyright (c) 2008-2016 Chris Eppstein Released under the MIT License. Compass is charityware. Please make a tax deductable donation for a worthy cause: umdf.org/compass – prkos Mar 6 '16 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.