1

I need to automount ftp, but not only at boot but always with some timeout. Btw this ftp server is mediaplayer. Please help. Ubuntu version 14.04.

Like usb but ftp.

  • also this mount point should be available to all users – LeonidMew Sep 11 '15 at 19:57
  • I use: curlftpfs#root:12345@192.168.1.226 /media/MediaPlayer fuse rw,uid=1000,umask=0777,user,suid,allow_other,exec,auto,utf8 0 1 but it not allow me to write anywhere. tryed all in mnt and /usr/share /usr/local/share. How to find writable folder? – LeonidMew Sep 11 '15 at 20:34
  • I even appear in nautilus, but no write able access. At least two folders must be writeable, internal hdd and usb flash on this media player – LeonidMew Sep 11 '15 at 20:42
  • I found a writable folder, its /media/MediaPlayer/mnt/usbmounts/sda3 but every time I write is says: unable to change owner – LeonidMew Sep 11 '15 at 20:47
  • I'm looking at WiFi FTP Server on Android to allow access from Ubuntu and I'm curious how this all turned out for you? – WinEunuuchs2Unix Oct 6 '19 at 1:27
1

You can try to use Autofs. Here is a good documentation/tutorial about it : https://help.ubuntu.com/community/Autofs

And here you'll find how to use it with FTP : https://wiki.archlinux.org/index.php/Autofs#FTP_and_SSH_.28with_FUSE.29

the Timeout setting at the master file level is the timeout before automatic disconnection after a period of inactivity.

Warning : FTP is very light to be used like a regular File System. You can have some bad performance due to the FTP protocol design. If you can do it, prefer ssh/scp with certificate authentication.

Best regards,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.