2

So I came to start up my computer as usual and was prompted to log in unusually. I couldn't log into my account or the guest account. It just kept bringing me back to the log in screen. I then searched for solutions, of which I tried

sudo chmod -R u+w /home/[username]
sudo chmod -R ug+rwx /home/[username]
chown -R [user-name]:[user-name] /home/[user-name]
sudo mv .Xauthority .XauthorityBak

None of these worked so I then created a live usb with boot repair on it, but still nothing.

These might make sense to some people though:
http://paste.ubuntu.com/12336440
http://paste.ubuntu.com/12336605

How can I fix this login issue?

  • 1
    Your fixes were rather making everything worse than solving the problem. One may not just chown -R its home directory or set permissions equally to all files in there. Some special files/directories need special permissions or to be owned by root to work! – Byte Commander Sep 11 '15 at 12:24
  • Yep, I can understand that. You may realise, that I'm not completely Linux savvy. I tend to search for solutions and then just throw them into the terminal. – mattwesti Sep 11 '15 at 12:31
  • I know and I've already seen many doing that mistake. I'm currently writing a question myself on how to revert such mistakes easily: askubuntu.com/q/672907/367990 – Byte Commander Sep 11 '15 at 12:41
  • So, do you think that I have changed certain things that I shouldn't have and that reversing them will be an issue? – mattwesti Sep 11 '15 at 12:50
  • Reversing them will solve the additional problem (that is maybe not noticeable yet) you created by trying those "fixes". The original problem will still be there though, but I am not sure about how to approach that yet. You should definitely restore the xauthority file: cp /home/YOURUSERNAME/.XauthorityBak /home/YOURUSERNAME/.Xauthority. That will also keep your backup copy. – Byte Commander Sep 11 '15 at 13:03
-1

try to install

sudo apt-get install gdm

and

sudo apt-get install lightdm

  • tried those two. the gdm came back with unable to locate package gdm and the lightdm came back with sub process /usr/bin/dpkg returned error code (1) – mattwesti Sep 11 '15 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.