I like to use pidgin instead of Empathy because I'm used to it, and because I have to venture into windows for more development than I would prefer.

In Ubuntu 11.10, I can't find any way to get to the buddy list. It opens, and just sits there in the messenger panel tray thing. From its previous behavior, I believe Pidgin usually starts up minimized-- you have to click on its system tray to show the buddy list. The messenger applet does not seem to support this functionality. Is this a bug, or am I just missing something obvious?

10 Answers 10


Check the value of the list_visible parameter in .purple/prefs.xml, if it is 0, close pidgin, edit and change it to 1, then restart pidgin.

<pref name='list_visible' type='bool' value='1'/>

You can also try the same with 'blist_autohide'

<pref name='blist_autohide' type='bool' value='1'/>
  • 2
    I don't find blist_autohide in that file
    – rubo77
    Commented Oct 21, 2014 at 9:42
  • This should be the accepted answer
    – Ichthyo
    Commented Jan 11, 2021 at 10:58

Faced the same problem. Completely reinstalling (purge and reinstall) pidgin and it's dependencies solved it for me. Try the following in a terminal.

Purge pidgin and its dependencies:

$ sudo apt-get purge pidgin pidgin-libnotify pidgin-data indicator-status-provider-pidgin

Clear stale archives:

$ sudo apt-get clean


Reinstall pidgin alongwith dependencies:

$ sudo apt-get install pidgin

This solved the issue for me. Pidgin now shows buddy list from indicator menu and when I launch Pidgin manually.

  • That solved it for me as well. Must have been an upgrade issue. Thanks!
    – Blank
    Commented Oct 25, 2011 at 16:08
  • Perfect solution ! By the way Pidgin/Ubuntu recreate the whole buddy list automatically, so you will not loose anything (at least in my case ;) )
    – Sliq
    Commented Aug 30, 2012 at 13:37
  • please add this to your answer: Backup you chat-history cp -a ~/.purple/logs/ ~/.purple-logs-bak then purge and reinstall pidgin
    – rubo77
    Commented Oct 21, 2014 at 9:39
  • 1
    Uninstalling is completely unnecessary. Check out George Brad's answer. Commented Dec 15, 2014 at 9:00
  • Did the trick in 16.04 LTS 64 bits. At some point the buddy list is not displayed anymore. It was still possible to contact me. Commented Jul 20, 2017 at 8:51

This issue still occurs on 12.04. Sometimes, the only way to get it to work is to killall pidgin and use the launcher from the dash. However, I came up with a solution that works every time.

Use the following command:

gksu gedit /usr/share/applications/pidgin.desktop (or use your favorite editor instead of gedit)

Add this to the bottom of the file and save:

[List Shortcut Group]
Name=Display Buddy List
Exec=pidgin %U

What this does is an an option to the pidgin launcher called "Display Buddy List" that always will show the list whenever selected. But, if the list is showing already, it will not open a second one.

So, long story short, if opening Pidgin from the messaging menu gives you that trouble, use the solution listed here. Even if it doesn't work by clicking the messaging menu option or using the launcher from the Dash, this will always work.

Note: To those wondering why I didn't advice to copy the Pidgin launcher to .local/share/applications, it is because the launcher in the messaging menu launches /usr/share/applications/pidgin.desktop. So, rather than editing the messaging menu, I advised to edit the original launcher.

  • 1
    This is a most excellent solution.
    – Ether
    Commented Jul 6, 2012 at 17:43

Just wanted to mention I tried all of the above and nothing seemed to work. Then when I went in to Tools -> Preferences and unchecked the Status "Use status from last exit at startup" and changed the "Status to apply at startup:" to "Available", things seem to work fine. I am unsure why this seemed to fix it, but so far I have restarted a couple times and it seems to be working now.


Removing my ~/.purple folder solved this issue for me, I had copied my home folder from 11.04 over to 11.10.

Warning: deleting ~/.purple means you'll have to setup your accounts and preferences all over again.

Note: After doing this I now also sometimes need to load Pidgin with the -f flag for the buddy list to show.


Had the same issue. One thing that worked for me was going to the Unity "envelope" menu (where mail and IM notifications are shown) and hit "Clear". Then going back to the same menu, I selected "Pidgin Internet Messenger" and suddenly the buddy list appeared.


I also had this bug. One thing resolve the issue for me: setting "Show system tray icon" to "Always" in pidgins preferences. I don't know why or how, but now everything is OK.


No need to remove the .purple directory

This worked for me:

sudo aptitude install --reinstall pidgin

This will keep your settings in pidgin

  • this is better : "sudo aptitude reinstall pidgin" it works for me on 16.04 ! Commented Aug 30, 2016 at 9:03

I've got the same bug on my pc, can temporary fix it with disable and re-enable account in accounts menu entry.


just start pidgin with -f key, seems like bug causing by network-manager. in gnome 3!


None of the solutions worked for me, seems there are more people like me judging from this bug: https://bugs.launchpad.net/ubuntu/+source/pidgin/+bug/879960 (in case somebody comes across this)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .