44
sudo apt-get install python-pip
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package python-pip

how to install python-pip in ubuntu:14.04?

75

python-pip is in the universe repositories, therefore use the steps below:

sudo apt-get install software-properties-common
sudo apt-add-repository universe
sudo apt-get update
sudo apt-get install python-pip
| improve this answer | |
  • sudo apt-add-repository universe Error : sudo: apt-add-repository: command not found – Ravi _SS Sep 11 '15 at 9:22
  • 1
    @Ravi_SS sorry, forgot the installation of apt-add-repository. Install with sudo apt-get install software-properties-common as described now in my answer. Start again with the first command. – A.B. Sep 11 '15 at 9:25
  • apt-get update is working fine, but sudo apt-get update is giving me error.. And also sudo apt-get install software-properties-common is not working. – Ravi _SS Sep 11 '15 at 12:15
  • On sudo apt-get install software-properties-common Err archive.ubuntu.com/ubuntu trusty/main libroken18-heimdal amd64 1.6~git20131207+dfsg-1ubuntu1 Could not resolve 'archive.ubuntu.com' – Ravi _SS Sep 11 '15 at 12:24
  • 3
    With Ubuntu 20.04 I replaced sudo apt-get install python-pip with sudo apt-get install python3-pip it works properly – Saddam Meshaal May 14 at 21:02
20

I ran into this problem trying to install pip for python2; e.i. I wanted pip2. What worked for me was this:

sudo apt-get update && sudo apt-get install python-pip

Hope this helps someone.

| improve this answer | |
  • 1
    This worked for me. – Viks Apr 26 '18 at 17:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.