0

I am using Firefox 40, and I don't really like the New Tab page, so I would really like to set it to the DuckDuckGo homepage, how can this be achieved so that when I click the New Tab button I get the DuckDuckGo homepage?

I have already done some research into this, but this is all that I found. And I am not looking for a way of customizing the look of the default New Tab page, so not pinning the tiles, nor rearranging them etc, no, instead I am looking to replace the New Tab page with another page. And I could not find any information on achieving this.

Information Update:

I have recently upgraded to Firefox 41, and the solution here no longer works for I cannot see the browser.newtab.url option. Has it moved or something or is this simply no longer achievable?

  • 2
    What does this have to do with Ubuntu? – Marty Fried Sep 10 '15 at 20:26
  • 1
    @MartyFried: Quoting the on-topic section of the help centre: Running third-party applications on Ubuntu.. – user364819 Sep 10 '15 at 20:33
  • 1
  • 1
    @bodhi.zazen: Can you post that as an answer please so that I can accept it. :) – user364819 Sep 10 '15 at 20:43
  • 1
    I agree with Marty Fried. The question has nothing to do with Ubuntu even tangentially. While it maybe on-topic as per the FAQ, I think superuser.com would be a more appropriate site for this question. – DK Bose Sep 11 '15 at 1:53
1

In Firefox 41 browser.newtab.url preference is missing in about:config.

Firefox 40 or versions prior to it allowed users to replace the New Tab Page with a custom web page or site like Google.com by changing the browser.newtab.url preference value in about:config to a desired URL.

From firefox 41 onwards you have to use the New Tab Override (browser.newtab.url replacement) to make changes to the New Tab.

  1. Download and install the add-on.

enter image description here

  1. Visit add-ons manager, click on its ‘Options’, enter the URL in place of about:newtab for which you want the new tab to open.

enter image description here

  1. Click ‘OK’ - then press Ctrl+T to open the new tab page to see if it is loading the site you’ve set above in the extension’s options.

PLEASE refer here

  • I am unable to see the images... – user364819 Dec 24 '15 at 18:42
  • Also, why is this so? Why did they decide to do this? – user364819 Dec 24 '15 at 18:46
  • @ParanoidPanda I believe. I don't know "why"? I will try to figure it out:) – Ravan Dec 25 '15 at 0:45
  • @ParanoidPanda images? – Ravan Dec 25 '15 at 0:52
  • It says "Imgur" in two places in your question just as text, and when looking in edit it says that there are links but with this for ![Imgur](URL). – user364819 Dec 25 '15 at 18:10
4

Please note that this answer only works for Firefox version 40 and below.


From https://support.mozilla.org/en-US/questions/1013039

In case you need more of a step-by-step:

  1. In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

  2. In the search box above the list, type or paste newtab and pause while the list is filtered

  3. Double-click the browser.newtab.url preference and enter your preferred page:

    Page thumbnails (default)    =>   about:newtab 
    Blank tab                    =>   about:blank
    Built-in Firefox home page   =>   about:home 
    Any other page               =>   full URL to> the page 
    

Press Ctrl+T to open a new tab and verify that it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy