3

I tried to use the command gnome-control center -l and it gave me an errors saying some shared objects are missing . This is the result :

gnome-control-center -l

libwayland-egl.so.1: cannot open shared object file: No such file or directory
Failed to load module: /usr/lib/i386-linux-gnu/unity-control-center-1/panels/libuser-accounts.so
Unknown option -l

Run /usr/bin/unity-control-center --help to see a full list of available command line options.

So I tried this and it also gave the same result :

unity-control-center -l

libwayland-egl.so.1: cannot open shared object file: No such file or directory
Failed to load module: /usr/lib/i386-linux-gnu/unity-control-center-1/panels/libuser-accounts.so
Unknown option -l

Run unity-control-center --help to see a full list of available command line options.

Following this thread I tried the following commands and those gave me the following results :

sudo apt-file update

sudo apt-file find libwayland-egl.so.1

libhybris: /usr/lib/i386-linux-gnu/libhybris-egl/libwayland-egl.so.1
libhybris: /usr/lib/i386-linux-gnu/libhybris-egl/libwayland-egl.so.1.0.0
libwayland-egl1-mesa: /usr/lib/i386-linux-gnu/libwayland-egl.so.1
libwayland-egl1-mesa: /usr/lib/i386-linux-gnu/libwayland-egl.so.1.0.0
libwayland-egl1-mesa-dbg: /usr/lib/debug/usr/lib/i386-linux-gnu/libwayland-egl.so.1.0.0
libwayland-egl1-mesa-lts-utopic: /usr/lib/i386-linux-gnu/libwayland-egl.so.1
libwayland-egl1-mesa-lts-utopic: /usr/lib/i386-linux-gnu/libwayland-egl.so.1.0.0
libwayland-egl1-mesa-lts-vivid: /usr/lib/i386-linux-gnu/libwayland-egl.so.1
libwayland-egl1-mesa-lts-vivid: /usr/lib/i386-linux-gnu/libwayland-egl.so.1.0.0

It said about missing dependency account plugin ubuntuone . So I tried installing it but it installed some packages meant for ubuntu mobile . I removed those wrong packages and reinstalled the previous ones following this thread and after that everything is good like before but the error I mentioned before about libwayland-egl.so didn't get solved . And still user-accounts.so shows failed to load .

How do I solve this ? I am trying to solve it because I can't access user-accounts from system settings . Whenever I try to access user accounts it always keep showing system settings over and over again . I can't even close it in anyway possible . It just keeps showing up .

6

I had a same problem with Cinnamon 2.8.6 on Ubuntu 14.04.4 LTS I managed to fix it by running:

sudo apt-get install libwayland-egl1-mesa-lts-trusty

Hope that helps.

0

Ubuntu official wiki page gives all the solution required :

https://wiki.ubuntu.com/Kernel/LTSEnablementStack

P.S : If you face above issues like me , thats probably because you don't have the recommended .so file installed properly . Always check if you have anything missing as mentioned in the stack .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.