0

I tried to connect to FTP via Nautilus on Ubuntu 14.04. When I tried the address for example, ftp://whs.servername.com, nothing happen, but I can connect it via FileZilla. If I tried with SFTP, it asked the username and passwors, but after I enter it, I got the following error message:

enter image description here

The ssh is work fine, and I can access another protocol like smb from Nautilus connect to server. Anyone knows how to solve this problem? I have another Ubuntu 14.04 in MBP, but it works to connect to FTP via Nautilus.

0

I already solved this problem by implementing a solution from here. The problem is proxy related, and then by running the following command now, I can connect to ftp by using nautilus.

gsettings set org.gnome.system.proxy autoconfig-url ''
gsettings set org.gnome.system.proxy ignore-hosts ['localhost', '127.0.0.0/8']
gsettings set org.gnome.system.proxy mode 'none'
gsettings set org.gnome.system.proxy use-same-proxy false
gsettings set org.gnome.system.proxy.ftp host ''
gsettings set org.gnome.system.proxy.ftp port 0
gsettings set org.gnome.system.proxy.http authentication-password ''
gsettings set org.gnome.system.proxy.http authentication-user ''
gsettings set org.gnome.system.proxy.http enabled false
gsettings set org.gnome.system.proxy.http host '' 
gsettings set org.gnome.system.proxy.http port 8080
gsettings set org.gnome.system.proxy.http use-authentication false
gsettings set org.gnome.system.proxy.https host ''
gsettings set org.gnome.system.proxy.https port 0
gsettings set org.gnome.system.proxy.socks host ''
gsettings set org.gnome.system.proxy.socks port 0

To make it permanent, change the proxy configuration in system settings > networks > proxy to use manual proxy and apply system widely.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.