0

No sound in my desktop Ubuntu MATE after new install. When I hit alsamixer I see my headphone is disabled and I have to enable it each time with right key, M then up key.

Couldn't find a satisfactory answer to this problem so I found the solution myself. Couldn't post it as a comment to any of the numerous questions users have regarding this issue because I don't have 50 reputation (...).

So here's the solution, please let me know if you find it useful:

  1. save the following two lines in a file called for example /usr/bin/amixer_script.sh

/usr/bin/amixer -c 0 cset iface=MIXER,name='Headphone Playback Volume' 100% /usr/bin/amixer -c 0 cset iface=MIXER,name='Headphone Playback Switch' 1+ toggle

  1. make it executable with sudo chmod +x /usr/bin/amixer_script.sh
  2. add /usr/bin/amixer_script.sh to System->Control Center->Startup Applications

There. Your script is launched at each bootup and you have sound.

  • Hello! Welcome to Ask Ubuntu. Please use the answer field below to post the solution of your problem :) – hg8 Sep 10 '15 at 8:07
1
  1. save the following two lines in a file called for example /usr/bin/amixer_script.sh

/usr/bin/amixer -c 0 cset iface=MIXER,name='Headphone Playback Volume' 100% /usr/bin/amixer -c 0 cset iface=MIXER,name='Headphone Playback Switch' 1+ toggle

  1. make it executable with sudo chmod +x /usr/bin/amixer_script.sh
  2. add /usr/bin/amixer_script.sh to System->Control Center->Startup Applications

There. Your script is launched at each bootup and you have sound.

0

Another solution : when alsamixer configuration is ok, run
sudo alsactl store 0

It will save your settings once for all.

"0" is for first soundcard , replace with "1" for saving second soundcard state .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.