Possible Duplicate:
How well do laptops with Nvidia Optimus work?

First question on here...

I recently bought an Alienware M11x R3 [8gb ram, Intel Core i5-2537M 1.4GHz (2.3GHz Turbo Mode, 3MB Cache), NVIDIA GeForce GT540 graphics with 1.0GB Video Memory and Optimus]. After a fair amount of gaming, it, 's time to let up on windows and dual-boot.

I was on 11.04 before with a Toshiba Satellite T135-S309, worked well enough. Now, I can't get the computer to utilize the driver on the new 11.10 -- System info tells me the driver is unknown, I can't get 3d effects out of it, and games run rather slowly. I tried updating with the driver from NVIDIA's site, but when it configures xorg.conf, lightdm fails and startx won't initiate lightdm. Mainly, I cannot get NVIDIA X server settings to work, as nvidia-xconfig requires restoring the backup to have any manager.

I saw a few posts about using Bumblebee and users having success, but I saw no results from using this. Don't see any switcheroo in the system. The BIOS has no way to dictate which graphics card is used, and all I'd really like is setting the 540m to always be used, or to have 3d enabled one way or another. Is there any way to configure Ubuntu to recognize/utilize the card?

`@:~$ optirun64 nvidia-settings -c :1

optirun64: command not found

@:~$ optirun nvidia-settings -c :1

(nvidia-settings:4304): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(nvidia-settings:4304): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(nvidia-settings:4304): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(nvidia-settings:4304): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

ERROR: Cannot open display ':1'.



I've given up any hope on running the NVIDIA on Ubuntu, but at the very least I'd like to find a way to enable 3D using the intel card. Any possibility in this? I've read things about blacklisting the NVIDIA card, but that didn't seem to work for me: It said permission was denied, even with sudo. I'm thinking if I can find a good driver for the intel, I can blacklist the NVIDIA and just use the intel.


This should work for you:


  • My bad, I wasn't clear, this is on 11.10. I don't seem to have switcheroo installed and can't find directions to install it.
    – Wane5tars
    Oct 16 '11 at 22:11
  • Did you install nvidia drivers before installing Bumblebee? Bumblebee worked fine for me in 11.10. In 12.04 the switcheroo is hosted in : /usr/src/linux-headers-3.2.0-22/include/linux Are you still in 11.10? The fact the you do not find vgaswitcheroo means that maybe you're using the wrong version of bumblebee or its installation went wrong.
    – Hanynowsky
    Apr 8 '12 at 22:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.