5

I've got Ubuntu 15.04 running on desktop with 6-core 5930K processor, msi x99s motherboard, 32gb ram, ssd and nvidia gtx 980ti. Quite surprisingly, the overall system performance is way lower than what was expected, much slower than my laptop. At least at the first glance, since the computer is new and I had no chance to run heavy computation on it. It seems that the problem is rooted in the new intel_pstate driver keeping the cpu frequency low.

Indeed, the output of cpufreq-info is

analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 0.97 ms.
  hardware limits: 1.20 GHz - 3.70 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 3.70 GHz and 3.70 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 428 MHz.

Any suggestions, what helds the cpu frequency so low would be appreciated.

My question seems to be related to Kubuntu 15.04 very slow despite very high CPU usage for every task and My cpu slows down after a while and does not recover

Though I had not tried switching off the intel_pstate option yet, since had a hope that it can be properly configured to fix the issue. But the hope almost disappeared after few hours of googling, staring at configs and fighting with intel_pstate.

Update:

sudo cpupower -c all frequency-info 
analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 0.97 ms.
  hardware limits: 1.20 GHz - 3.70 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 3.70 GHz and 3.70 GHz.
                  The governor "powersave" may decide which speed to use
                  within this range.
  current CPU frequency is 425 MHz (asserted by call to hardware).
  boost state support:
    Supported: yes
    Active: yes

glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: GeForce GTX 980 Ti/PCIe/SSE2
    GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted, 
    GL_KTX_buffer_region, GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
    GL_NV_conditional_render, GL_NV_conservative_raster, 
    GL_NV_path_rendering, GL_NV_path_rendering_shared_edge, 
    GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted, 
    GL_KTX_buffer_region, GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 
    GL_NV_conditional_render, GL_NV_conservative_raster, 
    GL_NV_path_rendering, GL_NV_path_rendering_shared_edge, 
    GL_EXT_render_snorm, GL_EXT_robustness, GL_EXT_sRGB, 
    GL_NV_blend_equation_advanced_coherent, GL_NV_conditional_render, 
    GL_NV_packed_float_linear, GL_NV_path_rendering, 
    GL_NV_path_rendering_shared_edge, GL_NV_pixel_buffer_object, 
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap, 

i7z output

Cpu speed from cpuinfo 3500.00Mhz
cpuinfo might be wrong if cpufreq is enabled. To guess correctly try estimating via tsc
Linux's inbuilt cpu_khz code emulated now
True Frequency (without accounting Turbo) 3499 MHz
  CPU Multiplier 35x || Bus clock frequency (BCLK) 99.97 MHz

Socket [0] - [physical cores=6, logical cores=12, max online cores ever=6]
  TURBO ENABLED on 6 Cores, Hyper Threading ON
  Max Frequency without considering Turbo 3598.97 MHz (99.97 x [36])
  Max TURBO Multiplier (if Enabled) with 1/2/3/4/5/6 Cores is  37x/37x/36x/36x/36x/36x
  Real Current Frequency 800.24 MHz [99.97 x 8.00] (Max of below)
        Core [core-id]  :Actual Freq (Mult.)      C0%   Halt(C1)%  C3 %   C6 %  Temp      VCore
        Core 1 [0]:       800.24 (8.00x)        2.38     8.1       0    91.4    28      0.7832
        Core 2 [1]:       800.14 (8.00x)        3.94    25.4       0    73.7    32      0.7549
        Core 3 [2]:       799.96 (8.00x)        22.9    76.7       0    18.1    27      0.7939
        Core 4 [3]:       799.93 (8.00x)        3.56    8.44       0    90.7    27      0.7604
        Core 5 [4]:       799.82 (8.00x)        1.11    3.16       0    96.6    28      0.7871
        Core 6 [5]:       799.83 (8.00x)        4.98    12.7       0    86.2    30      0.7421

C0 = Processor running without halting
C1 = Processor running with halts (States >C0 are power saver modes with cores idling)
C3 = Cores running with PLL turned off and core cache turned off
C6, C7 = Everything in C3 + core state saved to last level cache, C7 is deeper than C6

/proc/cpuinfo

grep -E '^model name|^cpu MHz' /proc/cpuinfo
model name  : Intel(R) Core(TM) i7-5930K CPU @ 3.50GHz
cpu MHz     : 422.324
  • Is it set to performance or powersave? Also, what does i7z say about the realtime freq? – mchid Sep 9 '15 at 23:56
  • @pavel, please execute the command sudo cpupower -c all frequency-info and post the results. – Charles Green Sep 10 '15 at 0:39
  • @pavel, also, please add the output of glxinfo | grep render - you may need to sudo apt-get install mesa-utils before you can run this command. – Charles Green Sep 10 '15 at 0:58
  • @charles-green added info – Pavel Sep 10 '15 at 18:38
  • @mchid performance mode. BTW, didn't notice difference between performance and powersave. Added i7z output. – Pavel Sep 10 '15 at 18:46
1

Disabling intel_pstate in grub config fixed current cpu frequency exactly to 3.5GHz which was again somewhat suspicious. And the overall performance was still slow. cpufreq-info reported acpi-cpufreq as a driver, however

lsmod |grep acpi 

showed nothing and modinfo acpi-cpufreq showed an error.

modprobe acpi-cpufreq 

executed silently with no effect.

Finally I've simply installed Ubuntu 14.04 and hey, everything is blazingly fast, even with intel_pstate.

fram@hydra:~$ cpufreq-info 
cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 0.97 ms.
  hardware limits: 1.20 GHz - 3.70 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 3.70 GHz and 3.70 GHz.
                  The governor "powersave" may decide which speed to use
                  within this range.
  current CPU frequency is 3.51 GHz.

Still don't know what was the reason and hope that updates won't return the problem back.

1

This could be attributed to the bios limiting cpu frequency scaling. To solve this on 14.04 and on 16.04 I've had to do the following:

Open grub:

sudo vim /etc/default/grub

Replace GRUB_CMDLINE_LINUX_DEFAULT line:

- GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
+ GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_pstate=disable processor.ignore_ppc=1"

Update grub:

sudo update-grub

Reboot then:

echo 1 | sudo dd of=/sys/module/processor/parameters/ignore_ppc
echo 2900000 | sudo dd of=/sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq 
echo 2900000 | sudo dd of=/sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq 
echo 2900000 | sudo dd of=/sys/devices/system/cpu/cpu2/cpufreq/scaling_max_freq 
echo 2900000 | sudo dd of=/sys/devices/system/cpu/cpu3/cpufreq/scaling_max_freq 

Worked for me. Check number of cpu cores and update all accordingly. You may want to put those extra lines in /etc/rc.local so they execute on every boot.

Ninja edit: Replace 2900000 above with the value in:

cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq
0

I had a similar problem with Ubuntu 14.04.3 using the LTS enablement stack for Vivid.

After tearing my hair out for about a week I worked out that it was because I had intel-microcode installed, it seems to conflict with kernel 3.19.

As soon as I removed it, the problem was gone.

0

Skylake is still being worked out as Phoronix tests show but Kernel 4.2 and upward are doing well so I suggest you install that from mainline ppa.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.