1

It seems that every task that is run on my system uses an excessive amount of CPU power. Monitoring CPU use via conky or top, opening a page in Firefox or searching for something in google suddenly spikes my CPU use to 100%.

Same for editing files in vim, or opening a pdf. Opening a document in Okular causes Xorg, kwin_x11, plasmashell, preload, and okular to spike to 20 to 30% CPU use.

I would think little of this, but my computer is unbearably slow. I cannot edit text files, navigate the web, or open documents without a huge CPU spike. Even writing this post in firefox is causing 30-50% CPU use via firefox, and 10 to 30% CPU use via Xorg

Any help and ideas are much appreciated.

EDIT

$ sudo modprobe msr
$ sudo rdmsr -a 0x19a
0
0
0
0

Suspend

$ sudo rdmsr -a 0x19a
0
0
0
0

CPU still at 500MHz. Should I do something about this?

$ cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor 
powersave
powersave
powersave
powersave

Lastly,

$ cd /sys/class/thermal
$ grep -r . *
cooling_device0/type:Processor
cooling_device0/power/control:auto
cooling_device0/power/async:disabled
cooling_device0/power/runtime_enabled:disabled
cooling_device0/power/runtime_active_kids:0
cooling_device0/power/runtime_active_time:0
grep: cooling_device0/power/autosuspend_delay_ms: Input/output error
cooling_device0/power/runtime_status:unsupported
cooling_device0/power/runtime_usage:0
cooling_device0/power/runtime_suspended_time:0
cooling_device0/cur_state:0
cooling_device0/max_state:3
cooling_device1/type:Processor
cooling_device1/power/control:auto
cooling_device1/power/async:disabled
cooling_device1/power/runtime_enabled:disabled
cooling_device1/power/runtime_active_kids:0
cooling_device1/power/runtime_active_time:0
grep: cooling_device1/power/autosuspend_delay_ms: Input/output error
cooling_device1/power/runtime_status:unsupported
cooling_device1/power/runtime_usage:0
cooling_device1/power/runtime_suspended_time:0
cooling_device1/cur_state:0
cooling_device1/max_state:3
cooling_device2/type:Processor
cooling_device2/power/control:auto
cooling_device2/power/async:disabled
cooling_device2/power/runtime_enabled:disabled
cooling_device2/power/runtime_active_kids:0
cooling_device2/power/runtime_active_time:0
grep: cooling_device2/power/autosuspend_delay_ms: Input/output error
cooling_device2/power/runtime_status:unsupported
cooling_device2/power/runtime_usage:0
cooling_device2/power/runtime_suspended_time:0
cooling_device2/cur_state:0
cooling_device2/max_state:3
cooling_device3/type:Processor
cooling_device3/power/control:auto
cooling_device3/power/async:disabled
cooling_device3/power/runtime_enabled:disabled
cooling_device3/power/runtime_active_kids:0
cooling_device3/power/runtime_active_time:0
grep: cooling_device3/power/autosuspend_delay_ms: Input/output error
cooling_device3/power/runtime_status:unsupported
cooling_device3/power/runtime_usage:0
cooling_device3/power/runtime_suspended_time:0
cooling_device3/cur_state:0
cooling_device3/max_state:3
cooling_device4/type:intel_powerclamp
cooling_device4/power/control:auto
cooling_device4/power/async:disabled
cooling_device4/power/runtime_enabled:disabled
cooling_device4/power/runtime_active_kids:0
cooling_device4/power/runtime_active_time:0
grep: cooling_device4/power/autosuspend_delay_ms: Input/output error
cooling_device4/power/runtime_status:unsupported
cooling_device4/power/runtime_usage:0
cooling_device4/power/runtime_suspended_time:0
cooling_device4/cur_state:-1
cooling_device4/max_state:50
thermal_zone0/mode:enabled
thermal_zone0/temp:27800
thermal_zone0/type:acpitz
thermal_zone0/power/control:auto
thermal_zone0/power/async:disabled
thermal_zone0/power/runtime_enabled:disabled
thermal_zone0/power/runtime_active_kids:0
thermal_zone0/power/runtime_active_time:0
grep: thermal_zone0/power/autosuspend_delay_ms: Input/output error
thermal_zone0/power/runtime_status:unsupported
thermal_zone0/power/runtime_usage:0
thermal_zone0/power/runtime_suspended_time:0
grep: thermal_zone0/emul_temp: Permission denied
thermal_zone0/trip_point_0_temp:105000
thermal_zone0/trip_point_0_type:critical
thermal_zone0/policy:step_wise
thermal_zone0/passive:0
thermal_zone1/mode:enabled
thermal_zone1/temp:29800
thermal_zone1/type:acpitz
thermal_zone1/cdev2_trip_point:1
thermal_zone1/power/control:auto
thermal_zone1/power/async:disabled
thermal_zone1/power/runtime_enabled:disabled
thermal_zone1/power/runtime_active_kids:0
thermal_zone1/power/runtime_active_time:0
grep: thermal_zone1/power/autosuspend_delay_ms: Input/output error
thermal_zone1/power/runtime_status:unsupported
thermal_zone1/power/runtime_usage:0
thermal_zone1/power/runtime_suspended_time:0
thermal_zone1/cdev3_trip_point:1
grep: thermal_zone1/emul_temp: Permission denied
thermal_zone1/trip_point_0_temp:105000
thermal_zone1/trip_point_0_type:critical
thermal_zone1/trip_point_1_temp:95000
thermal_zone1/trip_point_1_type:passive
thermal_zone1/policy:step_wise
thermal_zone1/cdev0_trip_point:1
thermal_zone1/cdev1_trip_point:1
thermal_zone2/mode:disabled
thermal_zone2/temp:20000
thermal_zone2/type:INT3400 Thermal
thermal_zone2/power/control:auto
thermal_zone2/power/async:disabled
thermal_zone2/power/runtime_enabled:disabled
thermal_zone2/power/runtime_active_kids:0
thermal_zone2/power/runtime_active_time:0
grep: thermal_zone2/power/autosuspend_delay_ms: Input/output error
thermal_zone2/power/runtime_status:unsupported
thermal_zone2/power/runtime_usage:0
thermal_zone2/power/runtime_suspended_time:0
grep: thermal_zone2/emul_temp: Permission denied
thermal_zone2/policy:user_space
thermal_zone2/passive:0
thermal_zone3/temp:26800
thermal_zone3/type:TMEM
thermal_zone3/power/control:auto
thermal_zone3/power/async:disabled
thermal_zone3/power/runtime_enabled:disabled
thermal_zone3/power/runtime_active_kids:0
thermal_zone3/power/runtime_active_time:0
grep: thermal_zone3/power/autosuspend_delay_ms: Input/output error
thermal_zone3/power/runtime_status:unsupported
thermal_zone3/power/runtime_usage:0
thermal_zone3/power/runtime_suspended_time:0
grep: thermal_zone3/emul_temp: Permission denied
thermal_zone3/trip_point_0_temp:53000
thermal_zone3/trip_point_0_type:passive
thermal_zone3/trip_point_1_temp:0
thermal_zone3/trip_point_1_type:passive
thermal_zone3/trip_point_2_temp:103000
thermal_zone3/trip_point_2_type:critical
thermal_zone3/trip_point_3_temp:100000
thermal_zone3/trip_point_3_type:hot
thermal_zone3/trip_point_4_temp:71000
thermal_zone3/trip_point_4_type:passive
thermal_zone3/trip_point_5_temp:63000
thermal_zone3/trip_point_5_type:active
thermal_zone3/trip_point_6_temp:58000
thermal_zone3/trip_point_6_type:active
thermal_zone3/policy:user_space
thermal_zone4/temp:44000
thermal_zone4/type:x86_pkg_temp
thermal_zone4/power/control:auto
thermal_zone4/power/async:disabled
thermal_zone4/power/runtime_enabled:disabled
thermal_zone4/power/runtime_active_kids:0
thermal_zone4/power/runtime_active_time:0
grep: thermal_zone4/power/autosuspend_delay_ms: Input/output error
thermal_zone4/power/runtime_status:unsupported
thermal_zone4/power/runtime_usage:0
thermal_zone4/power/runtime_suspended_time:0
grep: thermal_zone4/emul_temp: Permission denied
thermal_zone4/trip_point_0_temp:0
thermal_zone4/trip_point_0_type:passive
thermal_zone4/trip_point_1_temp:0
thermal_zone4/trip_point_1_type:passive
thermal_zone4/policy:user_space

CPUFREQ EDIT

Seems to fix my life. Sort of. Governor is ondemand and my computer is no longer lethargic. The modprobe and rdmsr commands gave identical output, only that my CPU seemed fine before and after suspend. However, applications still appear to use an oddly high percentage of CPU use.

Thanks a lot for the help. I'd be happy to keep debugging.

  • I am looking for sufferers of a very specific severe computer slow down issue, in order to acquire supporting data/evidence for the theory as to the root of the problem. Is your computer a LapTop? If yes what brand? And has it ever suspended since boot? Please provide the results for cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver and cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor and grep MHz /proc/cpuinfo. For the last one, do it while the computer is under some load. – Doug Smythies Sep 9 '15 at 18:21
  • Laptop. Dell. Yes. Driver is intel_pstate. Governor's were all powersave. Switched them to performance. CPUs were all ~500 MHz (max is 3000, normal is 2500). – Mauricio Sep 9 '15 at 18:53
  • You are a perfect candidate to help me. Please help. Also, I think, but am not sure, you will get your speed back. Please give awhile to write an answer. – Doug Smythies Sep 9 '15 at 18:56
  • Actually, what is your processor model number, as some newer ones these days do allow a minimum pstate of 5. Please see this, as it is the test I hope you can do. – Doug Smythies Sep 9 '15 at 19:06
  • Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz – Mauricio Sep 9 '15 at 19:16
2

Your computer (typically Dell LapTops on battery after resume from suspend) might be suffering from a situation whereby sometimes Clock Modulation becomes enabled. In its current form the intel_pstate driver is incompatible with Clock Modulation and it will drive the target pstate to minimum, regardless of load.

For your computer the minimum pstate is 6 and I think your processor has the extra Clock Modulation percentage bit, for a minimum modulation percentage of 83.3%, so the expected CPU frequency would be about 525MHz.

I believe the magnitude of this issue is not understood, and I am attempting to acquire supporting evidence (and I have a little now).

I also believe that the issue occurs when using the acpi-cpufreq CPU scaling driver, but its response is completely different. So much so that the typical user would probably not even notice. (and I have no evidence to support that claim other than having the tested the response curve of the driver to various Modulation percentages.)

Would you be willing do do the tests described in this answer? And also when using the acpi-cpufreq driver instead of the intel_pstate driver.

If you prefer to just get a fix and move on, then I would suggest disabling the intel_pstate driver, and your system will default to using the acpi-cpufreq driver.

To disable the intel_pstate driver edit, as sudo, /etc/default/grub and add intel_pstate=disable to the GRUB_CMDLINE_LINUX_DEFAULT line. Example, with other stuff that I use:

GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 intel_pstate=disable net.ifnames=1 biosdevname=0 crashkernel=384M-:128M"

You will need to run sudo update-grub afterwards.

  • Curious if you would know if this affects windows machines and how to acquire data from a windows machine to support the issue. – xtrchessreal Sep 9 '15 at 20:01
  • @xtrchessreal: See this which mentions windows, but has yet to be confirmed or denied that is is the same issue. Beyond that I wouldn't know, my focus is on the intel_pstate driver in linux. – Doug Smythies Sep 9 '15 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.