1

I have a windows 7 machine (already configured to connect to the LAN) and a Ubuntu 15.04 machine (yet to be configured to connect to the LAN).

On Windows 7, the configuration is as follows

  • 802.1x Authentication
  • Network Authentication method : Microsoft Protected EAP (PEAP)

  • Authentication method - (EAP-Token) (in Settings)

  • Authentication mode (user based Authentication)

I use TFA RSA to authenticate, using my username & pin + RSA token.

How do I configure my ubuntu machine to connect to the same network? What are the settings that I need to provide in Ubuntu.

  1. I dont see EAP-Token option in Ubuntu.
  2. Also the fact that it is Microsoft PEAP - Is this a problem?

As far as possible I would prefer that the network admin folks dont have to change anything on their end as its my choice to try to connect an ubuntu machine to this network.

Thank you very much for your help.

Update: Here are some logs from /var/log/syslog. Hopefully gives some insight. Obviously since this is not connected to the LAN, Im not able to easily copy and paste.

Auto activating connection 'LAN1'
Activation (eth0) starting connection 'LAN1'
Activation (eth0/wired): connection 'LAN1' has security, but secrets are required.
Activation(eth0) failed for connection 'LAN1'

device state changed: config -> needs auth (reason 'none')
libnm-util-CRITICAL **: get_secret_flags: assertion 'is_secret_prop (seeting,secret_name,error)'  failed
device state change: need-auth -> failed (reason 'no-secrets')
  • PEAP is not a problem, it works fine for my use (campus eduroam networks). If Network Manager doesn't support the tokens, try WICD. – muru Sep 9 '15 at 18:22
0

Open your Network Manager and use the Security tab.

Enable 802.1x Security and select Protected EAP (PEAP)

enter image description here

enter image description here

  • I did that. In addition, I give my username and for password I use pin+RSA token. and have use "Ask for this password every time" since RSA token changes .. But no luck. – smk Sep 9 '15 at 18:15
  • Did you read this? – A.B. Sep 9 '15 at 18:20
  • That is for wireless - no? Im on a wired network. But yes. There was no line system-ca-cert in my systems-connections folder for my connection – smk Sep 9 '15 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.