7

No output devices

I'm guessing the problem is that my motherboard is very recent; it's a Gigabyte GA-Z170X-Gaming 7 using the new Z170 (Skylake) chipset.

The output of lspci -v shows two "Audio device" blocks, but I was thinking one of them might be for my integrated graphics HDMI, and the other for my graphics card (Nvidia GTX 980 Ti) HDMI:

00:1f.3 Audio device: Intel Corporation Device a170 (rev 31)
    Subsystem: Gigabyte Technology Co., Ltd Device a036
    Flags: bus master, fast devsel, latency 32, IRQ 16
    Memory at da140000 (64-bit, non-prefetchable) [size=16K]
    Memory at da120000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel

01:00.1 Audio device: NVIDIA Corporation Device 0fb0 (rev a1)
    Subsystem: Gigabyte Technology Co., Ltd Device 36b7
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at dc080000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel

This similar questioner on 15.04 resolved their issue by installing an ALSA daily build. I tried that but nothing changed. Wondering if it's because I'm on 14.04 which probably has an older kernel. Should my next step be updating the kernel?

6

Apparently it is a kernel bug popping up from the combination of the Intel Skylake architecture, the 3.19 linux kernel (ubuntu 14.04) and (possibly) the Realtek ALC887 audio chipset (snd-hda-intel linux driver) which screws somehow the alsa drivers up.

The following procedure is listed at https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS but it's not up-to-date with ubuntu 14.04 (although it is totally equivalent):

Make sure the dkms package is installed:

sudo apt-get install dkms

Then download and install (e.g. with ubuntu software center) the .deb file from the latest vivid alsa build at https://code.launchpad.net/~ubuntu-audio-dev/+archive/ubuntu/alsa-daily/+packages

When I did it, it was the following build:

oem-audio-hda-daily-lts-vivid-dkms - 0.201509251531~ubuntu14.04.1

where the 2 keywords are 'lts-vivid' and 'ubuntu14.04'. That is what you are looking for.

My system is the following: Asrock MB with b150 chipset (ALC887 sound card) and Intel i5-6500K (Skylake) with 8GB RAM and an NVidia GTX960. I also did not see any audio device, except for the video card hdmi outputs. Very nasty bug, as there is so much confusion around the sound system (alsa and pulseaudio) in ubuntu apparently, so that to find the same bug report is quite difficult.

I know this is exactly what Abe commented last, but I would like to see it as an answer, clearer to see immediately without having to browse through the comments.

| improve this answer | |
  • Fixed my system, too! H110 chipset, intel i5-6600K, NVidia GTX960, 8GB RAM. – Lui Feb 11 '16 at 9:18
3

I found the problem. Just install this new driver like that :

sudo apt-add-repository ppa:ubuntu-audio-dev/alsa-daily
sudo apt-get update
sudo apt-get install oem-audio-hda-daily-lts-vivid-dkms

It worked for me with Ubuntu 14.04 with Asus Z170-p (Realtek ALC887)

| improve this answer | |
  • Thanks, I had linked to that solution in my question, but forgot to come back and say that it did solve my problem after I figured out what I was doing wrong. What actually happened is that I had been plugging into a port on my sound card with a heaphone icon (which the manufacturer put in the lower-left position which is normally the default output device). This worked fine on Windows, but Ubuntu for some reason needed me to plug into the regular output jack. – Abe Voelker Sep 24 '15 at 14:12
  • 1
    One thing to note about your solution is you aren't supposed to add that repository to your sources in Ubuntu 14.04 (you should actually get a warning about this in the console when you do apt-add-repository). You are supposed to manually download and install the vivid .deb from the package list. wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS – Abe Voelker Sep 24 '15 at 14:17
2

works for my gigabyte z170x gaming g1 motherboard as well. i use ubuntu xenial 16.04 but it was pretty much the same command. as for any specific issue, i needed to add this as well:

First, create /etc/modprobe.d/hda-jack-retask.conf containing:

# This file was added by the program 'hda-jack-retask'.
# If you want to revert the changes made by this program, you can simply erase this file and reboot your computer.
options snd-hda-intel patch=hda-jack-retask.fw,hda-jack-retask.fw,hda-jack-retask.fw,hda-jack-retask.fw model=generic

(For those who already have tried playing with hdajackretask the model=generic at the end is required for sound to work)

Second create /lib/firmware/hda-jack-retask.fw containing:

[codec]
0x11020011 0x1458a046 0

[pincfg]
0x0b 0x41014111
0x0c 0x414520f0
0x0d 0x01014010
0x0e 0x41c501f0
0x0f 0x42214010
0x10 0x41214010
0x11 0x41012014
0x12 0x37a790f0
0x13 0x77a701f0
0x18 0x500000f0

This will disable most ports but the port at the right of the optical port will work. I disabled the optical port as well but if you need it you can try to activate it with hdajackretask.

From my experiences, every time you mess with the ports you need to reboot into windows once to set the card the way you want before you can make the sound work on linux again. If you try to make the headphone port work, the other one will stop working and you will need to reboot into windows again. Trust me it is much easier to just buy a 3.5mm Y Splitter. There is more than enough gain on this board anyway.

You also need to edit /etc/pulse/daemon.conf and add these:

default-sample-format = s24le
default-sample-rate = 192000

Since we are talking about fixing issues with Z170X-Gaming G1, i might as well point out how to fix WiFi as well:

copy board-2.bin file from bug https://bugzilla.kernel.org/show_bug.cgi?id=111111 direct link: https://bugzilla.kernel.org/attachment.cgi?id=224831 into /lib/firmware/ath10k/QCA6174/hw3.0/

Then make a link or copy /lib/firmware/ath10k/QCA6174/hw3.0/firmware-4.bin into /lib/firmware/ath10k/QCA6174/hw3.0/firmware-5.bin as well.

That's it, now Sound and WiFi will work, i tested this with 17.04 without issues, i did not have to update alsa. Remember that any rebooting from Linux to Linux will mess up the sound, you need to shutdown every time.

| improve this answer | |
1

I did the following process to resolve the missing audio under Ubuntu 14.04.3 64-bit on my Gigabyte GA-H710-HD3 motherboard (Skylake, Intel H170 chipset):

sudo apt-add-repository ppa:ubuntu-audio-dev/alsa-daily
sudo apt-get update
sudo apt-get install oem-audio-hda-daily-dkms

(Note no specific Ubuntu variant in the package name)

Once that was installed, I rebooted and analogue audio was working again (note that HDMI audio was already working perfectly without any changes to the system, but I needed the analogue out for my older stereo system).

| improve this answer | |
  • 1
    Hi, I just want to add note that this procedure also works in Gigabyate H170-Gaming 3, running Kubuntu 16.04 LTS. Thanks @jeff! – swdev Aug 8 '16 at 8:52
1

I follow MttG in #2 but not work, it only show HDMI card, my system: core i5 6500 skylake, realtek ALC887 and using gtx 950 with HDMI to monitor, so, AFTER LONG TIME I FOUND:

sudo gedit /etc/asound.conf

That show:

defaults.pcm.card 1
defaults.pcm.device 1

BUT my device 1 is HDMI, and DEVICE 0 is REALTEK, I edit that to:

defaults.pcm.card 1
defaults.pcm.device 0

And It worked. So, just follow MttG and edit asound.conf, It will work on Ubuntu 14.04. Thanks MttG.

My sound setting was display Realtek after config:

sound setting screenshot

| improve this answer | |
0

I followed michael pillonel's instructions above, with one variation.

I have 3.16.0-60-generic kernel which was needed killer ethernet connection of MSI Z170a M5 gaming motherboard with i5 skylake which I custom built couple of days ago. To fix the sound issue I simply changed the last command with utopic.

For "vivid":

sudo apt-get install oem-audio-hda-daily-lts-vivid-dkms

For "utopic" or generic:

sudo apt-get install oem-audio-hda-daily-lts-utopic-dkms
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.