0

How to install wlan driver mt7601u ? file(mt7601Usta.ko) is missing while doing it?

i am facing a problem while setting up wlan connection for my new mediatek wlan adapter .

unable to setup the connection , while making it was showing that file is missing .

when i replaced the file which is downloaded externally from online , it is prompting as a invalid file .

help me to go wireless

3

1 Answer 1

2

There's a PPA with this driver. At least it worked for me. Connect via ethernet and run:

sudo apt-add-repository ppa:thopiekar/mt7601
sudo apt-get-update
sudo apt-get install mt7601-sta-dkms

The driver for this adapter was included in kernel 4.2. If you upgrade to Ubuntu 15.10 you just have to download a firmware file:

sudo wget -O /lib/firmware/mt7601u.bin https://github.com/porjo/mt7601/raw/master/src/mcu/bin/MT7601.bin

If you're using Ubuntu 16.04 or later there's no need to install or download anything.

6
  • I am afraid this driver won't build on new kernels for some reason. Kernel 4.2 has a native support.
    – Pilot6
    Oct 29, 2015 at 9:17
  • @Pilot6 Yes, I've used this PPA on Ubuntu 14.04 and 15.04. On Ubuntu 15.10 the adapter works out of the box. I already posted an answer on another question and marked this one as a duplicate. Oct 29, 2015 at 16:12
  • I'm running ubuntu 15.10, and it doesn't work out of the box because the mt7601u.bin firmware file is missing. What package is supposed to provide that file?
    – ʇsәɹoɈ
    Jan 24, 2016 at 20:01
  • @ʇsәɹoɈ I updated the answer on the duplicate question. Seems like I already had the firmware file from a previous manual installation. Feb 8, 2016 at 13:46
  • for 14.04 i have upgraded the kernel using this post askubuntu.com/a/696253/247787, restarted, downloaded a firmware file like described above, restarted again, it worked. Apr 10, 2016 at 15:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.