27

I am facing flickering in KDE Plasma 5.4. Flickering stops when I change Compositor Rendering Back-end To OpenGL 3 and then change again to OpenGL 2.

  1. OS: KUbuntu 15.04
  2. Graphics: Intel HD 4000
  • 3
    In my case, I just needed to switch to OpegGL 3.1. Some update probably changed it to OpenGL 2 and the flickering began. – Martin Vseticka Nov 23 '15 at 8:27
  • @MartinVseticka nope they restored feature ;) – Dawid Drozd Dec 8 '17 at 13:37
39

I was having the same issue but with a different graphics card and a different OS (Fedora 22 KDE spin). I just came across this:

https://ask.fedoraproject.org/en/question/69542/fedora-22-full-screen-tearingflickering-under-kde/

which has several options that seem to solve the problem under Fedora at least. I'm trying option 3 and it seems to be working so far, and the first two options are things that can be changed purely through the kde system settings app (shouldn't be specific to OS).

Hope this helps you!

EDIT: In an effort to make this answer better, I'm putting a summary of the link given above here. To solve there issue there are three options

  1. Go into System Setting > Hardware > Display and Monitor > Compositor and change the tearing prevention to "Full screen repaints"

  2. As an alternative, in the same menu change the compositor to XRender

  3. If you'd prefer to not do either of the above, create a script file in /etc/profile.d named kwin.sh (or anything ending .sh really). In that file place the line export KWIN_TRIPLE_BUFFER=1

This is recommended if your .xsession-errors file mentions that Triple Buffering is not available. To find this, I just opened the file in kwrite and searched for triple, sure enough it said not available. After making the file, that message is no longer present on subsequent reboots.

  • 3
    This pointed me in the right direction. In my case I set "Tearing Prevention" to None. Screen is perfect now. Using OpenGL 3.1. – cartland Mar 1 '16 at 2:56
  • I have had this problem on and off for about two years across Plasma versions. (Currently installed: 5.6.2.) It was particularly bad when unlocking from a lock screen. Either option 1 or option 2 fixed the problem for me, but I also tried setting tearing prevention to "Never" and that worked, too. Since that was the option that didn't give me a scary warning, I'm sticking with that for now. I'll edit this comment if problems crop up again. – JD Baldwin Jul 4 '17 at 4:09
  • the flickering disappeared instantly on my system ONLY when changing from OpenGL to Xrender (solution n° 2). – user47206 Jun 11 '18 at 12:07
  • To me using XRender worked fine, opengl 2 and 3 was causing issues. – Rodislav Moldovan Jul 2 '19 at 19:39
3

I have flickering too. I also found that changing compositor settings fixed it, but only temporarily. The reason this worked is that it restarts the compositor. I don't have a full solution yet, but restarting the compositor with SHIFT+Alt+F12 twice is an efficient workaround.

  • Worked for me also. Seems to only flicker when switching to workspace with either Chromium or Firefox open. – DrA7 Sep 13 '16 at 9:31
  • Restarting the compositor also worked to resolve flickering in the toolbars. – Douglas Gaskell Feb 11 at 17:57
1

I had that problem very extremely with KDE Plasma 5.9.5 on Arch Linux in a VirtualBox guest VM. The problem seems to have been solved by

pacman -S virtualbox-guest-utils
systemctl enable vboxservice.service
  • This is the only solution that worked for me. I'm guessing the previous version of vbox guest additions that came along with the virtual cd caused the problem. virtualbox-guest-utils command gave two options; I took the one with arch on it (my distro was arch). I was almost going to give up on KDE. Thanks! – Ébe Isaac Nov 16 '17 at 5:41
1

On my system Kubuntu 18.04 with NVIDIA proprietary driver none of the solution listed int he answer worked, for me disabling "Sync to VBlank" make the issue stop for now (a reboot was needed)

0

In case this helps anyone else searching for a similar issue: I had intermittent flickering in Kubuntu 15.10 on a Macbook Pro retina. The desktop would load without issue, however on around every other boot, at some point the display would start flickering when minimising/resizing windows. Option 1 'full screen repaints' fixed this for me.

0

I have the same problem with intel drivers on Debian .

It's a PSR bug.

So you must disable it.

In Debian I add in to

/etc/default/grub: GRUB_CMDLINE_LINUX=" i915.enable_psr=0".

And run

sudo update-grub, to regenerate /boot/grub/grub.cfg.
-1

had also that flickering with KDE on Kubuntu 15.10 running on a i5-3320M with integrated HD4000. it was really annoing my when i played games like mincraft in fullscreen.

After i stopped the compositor, no Fullscreen flickering. I acutally set startup without the composer, that is my soulution.

All other methodes written above had no affect.

Maybe this is a thing KDE developers need to fix, cause i read a lot about this on the net an many people using ivy-bridge cpu´s have this flickering problem.

Greetings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.