I've just upgraded to oneiric and a few seconds after logging into unity 3D, the whole desktop freezes. I tried unity --reset, unity --advanced-debugging, re-enable from the ccsm. The only thing I could do is restart lightdm from a tty and log in to unity 2D but it is too slow. My machine passes the unity support test. The interesting part is that the beta2 release worked just fine. I would file a bug, but I can't decide whether it's a unity/gtk3/compiz bug. -Has anyone met this issue before? -Is there any way I could use Unity 3D somehow, bypassing the issue? -What should I do to help debug this one?


I had the same issue (described in bug #728745) and I successfully solved it after activating the nvidia-173-updates driver in the additional drivers preferences (as suggested in this comment). It is said to disable hibernation and multiple screens.

Note that a newer driver version is mentioned in the bug thread (version 275.43, see comments #144 and #145) that is said to fix everything, but I was reluctant to try it, because it has to be installed manually (you have to disable Nouvau, exit X and run it from a terminal) and in the future updated manually (through the nvidia-installer program) and who knows how this might play with future Ubuntu updates. Anyway, 173 works fine for me for now, so if it ain't broken, don't fix it :)

  • Thanks for your reply. Unfortunately I use intel graphics thus no noveau driver is activated. One workaround was to manually downgrade to kernel version 2.6. – Csonka Bálint Feb 2 '12 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.