0

I have just upgraded from 14.04 to 15.04 and I'm getting some errors during start up;

[FAILED] Failed to start (null).
See "systemctl status lsassd.service" for details.

There are multiple instances of these errors for these items;

  • lwregd.service
  • dcerpcd.service
  • lsassd.service
  • lwiod.service
  • netlogond.service
  • eventlogd.service
  • lwsmd.service

I've run that command and get the following log messages;

Sep 09 08:25:18 XXXXXX systemd[1]: Starting (null)...
Sep 09 08:25:18 XXXXXX  lsassd[1320]: /etc/init.d/lsassd: 24: .: Can't open /usr/lib/likewise-open/init-lwsm.sh
Sep 09 08:25:27 XXXXXX systemd[1]: lsassd.service: control process exited, code=exited status=2
Sep 09 08:25:27 XXXXXX systemd[1]: Failed to start (null).
Sep 09 08:25:27 XXXXXX systemd[1]: Unit lsassd.service entered failed state.
Sep 09 08:25:27 XXXXXX systemd[1]: lsassd.service failed.

The other instances of the errors all have a similar error message. I've checked and the /usr/lib/likewise-open directory doesn't seem to be present any more.

I tried to install the package sudo apt-get install likewise-open but get the following message;

Package likewise-open is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  likewise-open

E: Package 'likewise-open' has no installation candidate

I had a look on the LikewiseOpen page and it states;

LikewiseOpen is now Beyond Trust - PowerBroker Identity Services Open Edition The Likewise website is gone, and links to it are broken.

We are running this machine as part of a windows domain and the LDAP access for the SAMBA shares all seems to be running ok. In the middle of the errors the ldapd.service starts successfully.

Getting all the AD working was a lot of trial and error and I'm not completely sure what got installed and exactly which bits are still needed. I followed a combination of the instructions; ActiveDirectoryHowto and LDAPClientAuthentication.

I've read a little bit about the switch to systemd but don't really understand the implications or if this has anything to do with my errors.

It would be nice to not have errors during start up but I'm not sure the best way to clean this up. How can I remove LikewiseOpen, what might break if I do or what can I update or replace it with?

0

There were three steps to resolving this issue;

  1. Uninstall the previous likewise-open packages;

    apt-get --purge remove likewise-open

  2. Download and install pbis-open;

    apt-get install pbis-open

  3. Create and enabled lwsmd.service;

    Ubuntu 15.04 join domain problem (pbis)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.