10

I have an installation of Ubuntu 15.04 that has been working fine for some weeks. Today, my box locked up to the point I had to power it off in order to clear the error. When I did so, it stopped booting.

When booting, it comes up and displays a cursor and nothing else.

I tried following the advice here: http://ubuntuhandbook.org/index.php/2013/11/reinstall-grub-ubuntu-wont-boot/ but when I do so, it gives me this error:

Installing for i386-pc  platform.
grub-install: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
grub-install: warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged..
grub-install: error: will not proceed with blocklists.

Any advice as to what to try next?

  • If you have a UEFI system it has two totally different ways to boot, UEFI and CSM. CSM - UEFI Compatibility Support Module (CSM), which emulates a BIOS mode If you boot in UEFI mode drive must be gpt partitioned and has an ESP - efi system partition. But you can boot in BIOS mode, but must install grub to the gpt's protective MBR and must have the bios_grub partition. You must have an UEFI system, and now are reinstalling grub in BIOS/Legacy/CSM mode without the bios_grub partition. If you want to convert to BIOS add the bios_grub partition. Or boot and reinstall grub in UEFI mode. – oldfred Sep 8 '15 at 18:14
  • This situation has happened to me after upgrading a working Debian PC. I'm at a total loss as to whether it's fixable. There's no space for mysterious extra partitions, and I'm stumped as to why they'd suddenly be necessary. – Boann Feb 18 at 5:16
12

Way too late to help you, but this might help someone else who, like me, landed on this page in search for a solution to this problem. A small partition has to be created on the disk and marked as a code EF02 "BIOS boot partition". Somewhere I read it should be 200MB, I only had room for a 1007.0 KiB one and it worked just the same.

  • Thanks for this. I was getting this error on chroot and discovered my /boot partitions were just Linux and not BIOS. grub-intall no longer reporting errors now. – spyderdyne Jun 26 '17 at 1:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.