1

I bought a new Laptop. Lenovo Y500 with the Intel Quad and GT650 SLI configuration. (maybe this is important)

I set the whole thing up to load Legacy BIOS primary. As usual I installed on the HDD Windows. In parallel, I installed Ubuntu on the internal mSATA 16GB SSD. Creating only 2 partitions, root and swap, both in the SSD. Also the bootloader is placed on the SSD, so I manually decide on every boot which drive and for that which OS should be loaded.

After the installation Ubuntu keeps only loading a black screen. When I hold Shift while staring, I get a GRUB loading. and absolutely nothing more. I cannot even switch with Ctrl-Alt-F1/2/3... to any console. Odd thing is that Ubuntu runs fine, when I start it in live-mode directly from the USB-drive.

I'm kinda clueless how to solve this problem, cause I'm not that "pro" with Linux, but like to do little works with it. Just tried to install 15.04, the "beta" 15.10 and for variety a Mint distro with Cinnamon. All leading to the same problem.

5
  • I would suggest that the issue here is the same as in the question:- askubuntu.com/questions/272570/… which has a very detailed answer. – James Lewis Sep 8 '15 at 16:36
  • I also found this question and tried to track the solution. Unfortunately it doesn't help. I tried to change the "set gfxmode" to "1920x1080" but I'm lost with the insertion of "nomodeset=1" option after installation. There is only said "do the same as in step 3", but of course there is no "Install Ubuntu" entry within the config file, after you installed Ubuntu. – renegade2k Sep 8 '15 at 17:47
  • I noticed one more strange thing: While installation Ubuntu keeps convertig the SSD to GPT. Isn't GRUB unable to run on a GPT drive? – renegade2k Sep 9 '15 at 0:46
  • Drives larger than 2.2T require GPT, and UEFI boot is also usually GPT, so GRUB is quite capable in that regard.... – James Lewis Sep 9 '15 at 10:24
  • Ok, so this is not the failure. I already tried to replace all quiet splash with nomodeset=1 and as I already got set gfxmode=1920x1080 in my grub.cfg now I should get a picture, but it's still black and still no console available. Also tried to run the "Grub Repair Tool", which re-installed GRUB on the SSD, but it doesn't help, too. – renegade2k Sep 9 '15 at 17:12
-1

Since nobody seems to have a clue, what's wrong with my book (which should truly not be a reproach) i just tried a few more things myself. Like using another tool to create a bootable USB drive, swap partition size, using another drive etc. Nothing seems to work...
Finnaly i found an unremarkable comment in a lenovo forum, which tells, that the problem is simply the UEFI system, which is always loaded first, even if you choose to use legacy BIOS only. For that you should use a full compatible UEFI Linux distro like Fedora. So i downloaded the newest image, burned it on my USB drive and got exact the same problem booting it the regular way. Not even the live mode works. But the Fedora image provides, in contrast to the Ubuntu image, another "EFI boot" menu entry. Booting this works fine and also after the installation it keeps working. You not even need to install any nVidia drivers or edit the boot options.
WiFi, Bluetooth, brightness control, SLI ... all this seems to be supported out of the box.
It's not the prefect solution, cause i'm Ubuntu fan, but if it's not working ... well, it's not working.
Hope this helps users of the same notebook-model, which can't get started with linux too, becase of the configuration.

5
  • Ubuntu is fully UEFI comapatible. You did not create a EFI partition. If you do not know how to do it, you could install in automatic mode without creating partitions manually. The installer could do it for you. – Pilot6 Sep 12 '15 at 10:56
  • Well, tell me then, why Fedora works and Ubunt not? Specially considering that Fedora only starts, when you choose "EFI boot", while Ubuntu does not even provide this option... I'm not about blaming Ubunt for anything, just want to help other owners of the Y500 to get started with Linux – renegade2k Sep 12 '15 at 11:00
  • Because you installed Ubuntu a wrong way. Or you installed a wrong (32-bit) version. It is hard to guess what you did wrong. – Pilot6 Sep 12 '15 at 11:01
  • I'm of course installing 64 bit... And what you mean, i installed it "the wrong way"? I boot my USB drive, choose "install Ubuntu" and choose the option to delete my 1GB SSD and install Ubunt on it. Anything else happens on it's own. So It's not my fault, doing false configuration, if you want to say this. It's exact the same way i installed Fedora. – renegade2k Sep 12 '15 at 11:03
  • According to your question you started to create partitions manually. You could set bios to UEFI mode and let the installer create partitions for you. Or create them manually but in a correct way with EFI partition, etc. – Pilot6 Sep 12 '15 at 11:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.