4

After I installed my new keyboard, I discovered that pressing Ctrl+Alt+Fn keys no longer brings me to the tty screens(nothing happens), but sudo chvt 1 in the terminal emulator can start the tty. Meanwhile, Ctrl+Alt+F7 could bring me back to the x-window.

My keyboard is i-rocks IK6 (I didn't have such problem when using my old Logitech K120 keyboard)

How should I fix this problem? My system is Ubuntu 14.04 with Kernel 3.19.0-27-generic

p.s. I'm not an English Speaker so please forgive my English and ask me for details if I failed to express clearly...

  • please try sudo service tty1 restart and then try to login to tty using Ctrl+Alt+F1....any change?? – Ravan Sep 21 '15 at 13:18
  • 2
    Does your keyboard have a Fn combination key? This can be an issue if the OS autoenables the Fn key, in which you have to press it to disable it (ie, Ctrl + Alt + Fn + F1 might work). – Zzzach... Oct 19 '15 at 2:57
  • 2
    The kbd has a Windows and application keys disabled function. It is turned on and off using [Fn][F11]. – NZD Nov 13 '15 at 20:04
  • @userunknown Done. – NZD Nov 17 '15 at 5:51
0

I experienced a similar problem in my Dell Precision 5510 after a login loop that seems to happen due to a recent update of Ubuntu 14.04 LTS.

I finally found that the ESC key has a small Fn icon attached so I combined this with the Fn key and the blockade was released. Ctrl+Alt+F1 worked now and I could log in from the console.ç

çI have to fix now the issue of the login loop... I'll try with the suggestions I already found here.

0

The i-rocks IK6 Crystal USB Keyboard has, what they call, a Windows and application keys disabled function.

The function is turned on and off using Fn + F11.

There is even a small Windows icon on the F11 key.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.