1

I've just recently installed Ubuntu 14.04 on my computer, and I'm quite the noob still.

I have managed to get Diablo 3 working through Wine though, but I'm encountering one final problem.

Quite often, my keyboard would seem to stop responding. The caps lock/num lock keys still toggle on and off, but none of the others seem to have any effect.

I've found a way to get the keyboard to respond again by pressing ESC two or three times. This is an annoying problem though, and I'm sure there's a reasonable explanation for it. Can anyone help me find it?

2
  • 1
    Welcome to Ask Ubuntu, try disable auto repeat. open terminal an run xset r off, run the game. if it does not work you can return it back with xset r on – user.dz Sep 8 '15 at 7:17
  • 1
    Hello. Thanks for your response. Disabling auto repeat did not solve my problem. – Robin Didriksen Sep 8 '15 at 9:11
2

If you're using Ubuntu with the Unity desktop, what might happen when you play is that you press the Alt key. That's the key which by default brings up the Unity HUD. Because of the way Wine and X11 interact, you don't see it but it's there and now it's "stealing" input. That is why pressing Esc cures the problem.

You can rebind that. Install CompizConfig settings manager, click on the Unity Plugin and in the "General" tab, redefine "Key to show HUD when tapped". I bound it to Ctrl+Alt.

You could also bind the functionality of the Alt key in-game to some other key so you don't have to tap it when you want to see what loot there is on the floor.

If you accidentally tap the Windows key, something similar might happen. This is the key which usually invokes Unity Dash (think Windows start menu). It's strange why Blizzard did not add an option to disable the Win key in D3. They have it in SC2.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.