5

I want to update qt 5.4.1 to Qt 5.5 or 5.4.2 because I want to test KDE Plasma on WayLand.

Note: Please provide solution that consume least network resources as I have limited bandwidth. KUbuntu 15.04

5
  • Note Please provide your Ubuntu version :)
    – A.B.
    Sep 8 '15 at 5:31
  • KUbuntu 15.04 Updated
    – AhmedBilal
    Sep 8 '15 at 5:33
  • int_ua Yes, I am using Kubuntu 15.04
    – AhmedBilal
    Sep 8 '15 at 5:39
  • Just curious, what are the reasons to update? Is it segfaulting on every connect/disconnect of an external display? bugs.kde.org/show_bug.cgi?id=341497
    – int_ua
    Sep 8 '15 at 13:28
  • int_ua Because, I want to test Wayland
    – AhmedBilal
    Sep 9 '15 at 3:44
2

I advise you to install a virtual machine and install Ubuntu 15.10 indide this environment. Wily includes Qt 5.4.2.

Do not try to update your Vivid system with Qt 5.4.2.

1
  • 1
    Very good advice! :-)
    – Fabby
    Sep 8 '15 at 20:43
2

As mentioned in other answers, this is not really recommended and may cause issues, however, if you really want it, go HERE and download the .run installer or

wget download.qt.io/official_releases/online_installers/qt-unified-linux-x64-online.run

chmod +x qt-unified-linux-x64-online.run

~/qt-unified-linux-x64-online.run

This will start the qt 5x installer.

2
  • And please share your results afterwards :)
    – int_ua
    Sep 8 '15 at 9:34
  • 1
    I decide not to give it try as it is around 800MBs. Second, I replied after many days because my laptop bios get corrupted and I fixed it. Thank you everyone. Hope to test it when 15.10 released.
    – AhmedBilal
    Sep 13 '15 at 8:32
1

Short: not ready yet.

General information is on this page: https://wiki.ubuntu.com/Touch/QtTesting

3
  • Ok. Then how to install 5.4.2?
    – AhmedBilal
    Sep 8 '15 at 5:40
  • Well, basic algorithm for software not available in official repositories is 1) Try finding PPAs with newer versions, if that fails - 2) Try checking for package availability on official webpage and if that fails - 3) Try building and installing from sources. But that can be quite challenging, unfortunately.
    – int_ua
    Sep 8 '15 at 9:39
  • Looks like Mark found 2) in the other answer, please share your results if you decide to try it.
    – int_ua
    Sep 8 '15 at 9:40
0

Answer is totally based on my experience,and the same reason why I'm here,Searching for this same answer. Well now I have figured it out for me.

http://www.qt.io/download-open-source/

Just visit the link and download the offline installer for your machine and go through the simple click steps.I'm using ubuntu 14.04 and it worked for me pretty fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.