0

This question already has an answer here:

I have no problem with wired connection, but wifi is not even an option on my newly installed xubuntu 15.04. I found similar question (Wifi not detected Xubuntu 13.10) and run the commands in terminal, here is the output:

op@op:~$ lspci -knn | grep Net -A2
06:02.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)
    Subsystem: Hewlett-Packard Company Broadcom 802.11b/g WLAN [103c:1355]
    Kernel driver in use: wl
op@op:~$ lsmod | grep -e wl -e b43
wl                   6152192  1 
cfg80211              462848  1 wl

This is what I have after running it again:

op@op:~$ lsmod | grep -e wl -e b43
b43                   401408  0 
bcma                   49152  1 b43
mac80211              626688  1 b43
cfg80211              462848  2 b43,mac80211
ssb                    57344  1 b43

op@op:~$ sudo apt-get remove --purge bcmwl-kernel-source
[sudo] password for op: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'bcmwl-kernel-source' is not installed, so not removed

op@op:~$ sudo apt-get install linux-firmware-nonfree
Reading package lists... Done
Building dependency tree       
Reading state information... Done
linux-firmware-nonfree is already the newest version.
The following packages were automatically installed and are no longer required:
  dkms linux-headers-generic linux-image-generic thermald
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded.

No files to remove, no files to install and still no wifi.

Any ideas???

Here is what I tried and collected as much info as I could. Please look: Uninstalled all wifi drivers from the system:

sudo apt-get remove --purge bcmwl-kernel-source
sudo apt-get remove --purge linux-firmware-nonfree
sudo app-get autoremove

Restart. Restart hangs forever. Power Down. PC comes back up with “System program problem detected” Installing linux-firmware-nonfree

sudo apt-get install linux-firmware-nonfree Looks good so far:

Preparing to unpack .../linux-firmware-nonfree_1.16_all.deb ...
Unpacking linux-firmware-nonfree (1.16) ...
Setting up linux-firmware-nonfree (1.16) ...
op@op:~$ 

Unplug Ethernet cable and restart. no wifi please see screenshot: http://imgur.com/ow5zUfF Plug Ethernet cable back removing linux-firmware-nonfree installing bcmwl-kernel-source and it hangs after installing no prompt available system is workable just terminal hanging. Please see bellow: Loading new bcmwl-6.30.223.248+bdcom DKMS files... First Installation: checking all kernels... Building only for 3.19.0-28-generic Building for architecture i686 Building initial module for 3.19.0-28-generic Done.

wl: Running module version sanity check. - Original module - No original module exists within this kernel - Installation - Installing to /lib/modules/3.19.0-28-generic/updates/dkms/

depmod....

DKMS: install completed.

NO PROMPT! RESTARTING. Hangs on the Xubuntu logo, Doesn’t restart. Power down. Comes back same story. No wifi. Since this was not an issue in Xubuntu 14 should I downgrade?

marked as duplicate by Pilot6, user364819, Community Sep 10 '15 at 23:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Just run the commands. The worst that can happen is you'll lose your WiFi connectivity, which you don't have. Can you edit in a direct link to the question you're referring to? – TheWanderer Sep 8 '15 at 0:31
  • Do the commands in the answer. I can confirm these work on 14.04. – TheWanderer Sep 8 '15 at 0:46
  • Did not help, I opened Software & Updates here is what it shows: – pripe Sep 8 '15 at 1:30
  • You need to reboot afterwards. Did you do that? – TheWanderer Sep 8 '15 at 1:32
0

You tried everything but the correct command. To install firmware for your adapter you need to purge bcmwl-kernel-source and run

sudo apt-get install firmware-b43-installer
  • This is awesome!!! Thank you, Thank you, Thank you Pilot6! Wireless works now! I was truly looking through the questions for similarity but did not see the one you suggested as duplicate. I'm using Linux only for 2 months so it is all new for me. What do I do with my question since it is duplicate? Delete it? Sorry it doesn't let me to do the vote for you since I have less then 15 reputations (what ever it is :)) – pripe Sep 10 '15 at 23:05
  • @pripe You are welcome. Just leave the question as it is. It wall show the way to other people with similar problems. – Pilot6 Sep 11 '15 at 7:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.