2

After fixing another issue with missing packages, this is what I get when I try to startup steam:

Running Steam on ubuntu 14.04 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

I've tried reinstalling several times, didn't work. Also tried deleting the appcache like some other answers said.

Any help greatly appreciated.

ps. what do I have to learn to understand these error messages

Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
0

Run the following command to install that driver (swrast_dri.so):

sudo apt-get update
sudo apt-get install libgl1-mesa-dri libgl1-mesa-dri:i386

Please post any errors, thanks!


Usually, when I've seen this error, running:

sudo apt-get clean
sudo apt-get update
sudo apt-get dist-upgrade

fixed the issue.

However, sometimes you may need to try and install (or uninstall) stubborn applications individually to get things done.

To understand the message, install the needed dependencies individually to see what the issue is (or this may fix the issue):

sudo apt-get install --reinstall libcheese-gtk23 libcheese7

If the next error message says blah blah blah depends on blah blah blah, try installing blah blah blah and go from there.

|improve this answer|||||
  • Here you go: pastebin.com/XxsbZgva – uniqueID Sep 7 '15 at 22:32
  • @user223432 askubuntu.com/a/671162/167115 – mchid Sep 7 '15 at 23:46
  • @user223432 have you performed a dist-upgrade after installation? did you enable the universe, multiverse and the other repositories? you need to do this stuff. – mchid Sep 7 '15 at 23:48
  • did the upgrade, I've enabled the repositories long ago – uniqueID Sep 8 '15 at 0:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.