1

I have a virtualbox 'slackware 14' image that works fine in Opensuse 13.2, Windows 8.1 and Windows 7, I just export and inport it, and change the network adapter. On Ubuntu however, things not just works, from slackware I could ping only the host and but not any no other devices on the network. On the Ubuntu quest however I have access to the internet and all other devices on the network. The network is configured as 'bridge adapter', as on all other VirtualBox scenarios.

Virtualbox 4.3.28

On Ubuntu I use the network manager, and enabled ssh (as this also was disabled on standard install).

Network manager (Wired connection)

Manual

192.168.2.150 Mask 255.255.255.0 Gw 192.168.2.222 DNS 8.8.8.8, 8.8.4.4 Searh Domain creat route (none)

IpTables produce this

gerrie@Yoga-15:~$ sudo iptables -L [sudo] password for gerrie: Chain INPUT (policy ACCEPT) target prot opt source destination
Chain FORWARD (policy ACCEPT) target prot opt source destination
Chain OUTPUT (policy ACCEPT) target prot opt source destination

route -n produce

Destination Gateway Genmask Flags Metric Ref Use Iface 0.0.0.0 192.168.2.222 0.0.0.0 UG 0 0 0 eth0 192.168.2.0 0.0.0.0 255.255.255.0 U 1 0 0 eth0

I even tried

echo 1 > /proc/sys/net/ipv4/ip_forward

Every body says you just need 'bridge adapter' on virtualbox.

What must still be done to enable the virtual machine (192.168.2.171) to ping say the gateway at 192.168.2.222? I tried quite a few  
0

"You just need bridge adapter"

Shutdown your VM. In the settings for the machine's Network Adapter, make sure Attached To: "Bridged Adapter" is selected. And also in Name: make sure the name of your WAN facing adapter is selected (ie, eth0, eth1, or whatever yours is).

  • I do have bridge adapter settings, but it works as 'host only' , see ""The network is configured as 'bridge adapter', as on all other VirtualBox scenarios. This is what is so strange.. it just does not work on Ubuntu. I was ab le to use this same set-up on all other host set-ups but UBUNTU. >> ## Adapter Network settings.. >> Enable ticked, Attach to Bridge Adapterm Name eth0 (the only one available),Advance Intel Pro, Promiscuous Deny, Cable Connected ticked.It must be something else. – user1531982 Sep 8 '15 at 7:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.